php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15576 Got "Warning: Problem with method call. Report this bug in xxx.php" error
Submitted: 2002-02-15 14:06 UTC Modified: 2002-06-01 10:01 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: wine at bachi dot ch Assigned:
Status: Not a bug Package: Class/Object related
PHP Version: 4.0.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wine at bachi dot ch
New email:
PHP Version: OS:

 

 [2002-02-15 14:06 UTC] wine at bachi dot ch
Got this rather strange error msg. that asks for a bug report. Ok here we go, it happens here - when I try to 

1. generate an object from class objectFactory,
2. inside a class method,
3. and returning a reference to it (without the reference it worked)

$factory = &objectFactory::install();

class objectFactory
{
...
function &install()
    {
        global $globar;

        if (!$globar[objectFactory])
        {
            $globar[objectFactory] = new objectFactory();
        }
        return $globar[objectFactory];
    }
}

Hope that helped.. 
Cheers - Martin

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-16 05:46 UTC] sander@php.net
Can't reproduce with the latest CVS. Can you try the latest CVS?
 [2002-02-18 04:23 UTC] wine at bachi dot ch
Sorry, can't - we need to upgrade our software first. Exept the error msg it works ok, so a '@' solves my problems.

Thx - Martin

 [2002-06-01 10:01 UTC] mfischer@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2002-08-27 08:06 UTC] arash at yalpani dot de
I have this problem with php4.2.2, when making a static function call.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 02:01:23 2019 UTC