php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15572 apxs check fails because of missing quotes
Submitted: 2002-02-15 11:14 UTC Modified: 2002-03-04 12:47 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ralf dot nyren at educ dot umu dot se Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 4.1.1 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ralf dot nyren at educ dot umu dot se
New email:
PHP Version: OS:

 

 [2002-02-15 11:14 UTC] ralf dot nyren at educ dot umu dot se
A little glitch in sapi/apache/config.m4 causes the apxs check of working -S option to fail. Although the compile succeeds the installation isn't performed correctly, at least not when using INSTALL_ROOT.

The patch included below fixes the problem.

regards, Ralf Nyr?n

diff -ur php-4.1.1.orig/sapi/apache/config.m4 php-4.1.1/sapi/apache/config.m4
--- php-4.1.1.orig/sapi/apache/config.m4        Mon Nov 19 01:52:02 2001
+++ php-4.1.1/sapi/apache/config.m4     Fri Feb 15 15:22:47 2002
@@ -41,7 +41,7 @@
   PHP_SAPI=apache
 
   # Test whether apxs support -S option
-  $APXS -q -S CFLAGS=$APXS_CFLAGS CFLAGS >/dev/null 2>&1
+  $APXS -q -S CFLAGS="$APXS_CFLAGS" CFLAGS >/dev/null 2>&1
 
   if test "$?" != "0"; then
     APACHE_INSTALL="$APXS -i -a -n php4 $SAPI_SHARED" # Old apxs does not have -S option

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-04 12:04 UTC] porter at caip dot rutgers dot edu
Same exact problem but the fix didn't help me.  Same thing happens for 4.1.1 and 4.1.2.  Also on Solaris 7.

I just get the apxs usage message.

Note:  Currently running Apache 1.3.22 and PHP 4.1.0, in case remnants from those could be hosing it.
 [2002-03-04 12:47 UTC] derick@php.net
Patch applied in CVS, this will be in 4.2.x

Derick
 [2002-03-04 12:47 UTC] porter at caip dot rutgers dot edu
I apologize to Ralf & everyone!  It's my (cached) configuration mistake.  Ralf's fix is good.  Thanks Ralf!

-Adam
 [2002-03-04 12:47 UTC] derick@php.net
Patch applied in CVS, this will be in 4.2.x

Derick
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 02 21:04:48 2022 UTC