php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1557 connection to oracle fails sometimes
Submitted: 1999-06-17 06:04 UTC Modified: 1999-12-08 06:46 UTC
From: stefang at feedback dot de Assigned: thies (profile)
Status: Closed Package: Oracle related
PHP Version: 3.0.9 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stefang at feedback dot de
New email:
PHP Version: OS:

 

 [1999-06-17 06:04 UTC] stefang at feedback dot de
Our scripts have to connect to a remote database. Sometimes
it works fine, sometimes oracle errors appear like:

"Unable to connect to ORACLE (ORA-12705: invalid or unknown NLS
                            parameter value specified)"

OR "null password given" (but not at the moment, so I can't give you
                          the original message!)

The enviroment (ORACLE_HOME, ORACLE_SID, ORA_NLS, NLS_LANG) and 
the ora_logon command should be alright, because sometimes the 
db connect works without any error! 

what is happening here?

system php is running on:
- linux redhat 5.2 (kernel 2.0.36)
- apache 1.3.6
- php 3.0.9 configured with:
  ./configure  --with-apxs=/usr/local/www/bin/apxs 
               --with-oracle=/usr/local/oracle8.0.5/product/8.0.5 
               --without-gd
- the php3.ini file is the original one (only one include_path added)
- oracle SQL*Net 8.0.5.0.0

remote system oracle is running on:
- solaris 2.6
- oracle 7.3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-07-10 12:11 UTC] thies at cvs dot php dot net
please try to reporduce and send us a code-snippet (seems like a mem-overwrite somewhere else).
 [1999-10-19 07:04 UTC] thies at cvs dot php dot net
i've fixed something in current CVS (> 3.0.12) please try again.

 [1999-12-08 06:46 UTC] stefang at feedback dot de
Thank you very much for your efforts !!!

We found a reason for the problems described in this report:
Every time a php script sets wrong enviroment variables
(e.g. a not existing path) and the db connect fails, other
php scripts, although setting the right enviroment, run
into errors connecting to the database.
So everything seems to run alright until the 'bad' script
is executed by the server.

We solved the problem by setting the enviroment variables
(ORACLE_HOME, ORACLE_SID, ORA_NLS, NLS_LANG) in the
apache start script 'apachectl' and not in the php scripts
itself.


Yours,
  Stefan Grosse
  stefang@feedback.de
  Feedback GmbH, Regensburg, Germany
  http://www.feedback.de


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jan 18 05:01:23 2021 UTC