php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15500 segfault on pear-get list
Submitted: 2002-02-11 07:36 UTC Modified: 2002-02-17 11:58 UTC
From: jan at horde dot org Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.0CVS-2002-02-11 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jan at horde dot org
New email:
PHP Version: OS:

 

 [2002-02-11 07:36 UTC] jan at horde dot org
When calling pear-get list php segfaults with the following bt:

#0  0x403c8013 in memcpy () at ../sysdeps/generic/memcpy.c:64
#1  0x8083d13 in _mem_block_check (ptr=0x8305e44, silent=0, __zend_filename=0x825bb68 "overload.c", __zend_lineno=606, 
    __zend_orig_filename=0x0, __zend_orig_lineno=0) at zend_alloc.c:667
#2  0x8083cce in _mem_block_check (ptr=0x8305e44, silent=1, __zend_filename=0x825bb68 "overload.c", __zend_lineno=606, 
    __zend_orig_filename=0x0, __zend_orig_lineno=0) at zend_alloc.c:659
#3  0x80828fc in _efree (ptr=0x8305e44, __zend_filename=0x825bb68 "overload.c", __zend_lineno=606, 
    __zend_orig_filename=0x0, __zend_orig_lineno=0) at zend_alloc.c:224
#4  0x81053c4 in overload_call_method (ht=2, return_value=0x83ba3b4, this_ptr=0x83ba87c, return_value_used=1, 
    property_reference=0xbfffd958) at overload.c:606
#5  0x81b1adb in call_overloaded_function (T=0xbfffd94c, arg_count=2, return_value=0x83ba3b4) at ./zend_execute.c:953
#6  0x81b53b8 in execute (op_array=0x837a244) at ./zend_execute.c:1660
#7  0x81b7185 in execute (op_array=0x83827a4) at ./zend_execute.c:2141
#8  0x8095874 in zend_execute_scripts (type=8, retval=0x0, file_count=3) at zend.c:810
#9  0x80a6115 in php_execute_script (primary_file=0xbffff7d0) at main.c:1330
#10 0x807b0cf in main (argc=4, argv=0xbffff854) at php_cli.c:556

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-17 10:14 UTC] jan at horde dot org
Yeah, that's fixed now, thanks!

Btw, I don't know if this is the intended behaviour, but I get debug messages from the Zend engine to the console if I compiled php --with-debug and run 'pear-get list'
 [2002-02-17 10:17 UTC] jan at horde dot org
And I get the following error message if I try to run 'pear-get info XXX' both with installed and uninstalled packages:

Fatal error: Cannot instantiate non-existent class:  pear_common in /usr/local/bin/pearcmd-info.php on line 3
/usr/local/bin/pearcmd-info.php(3) : Fatal error - Cannot instantiate non-existent class:  pear_common
 [2002-02-17 10:33 UTC] mj@php.net
This bug has been fixed in CVS.


 [2002-02-17 11:58 UTC] jan at horde dot org
Hm, isn't pear-get meant to be used with remote (or installed) packages opposed to pear? It seems that is just calls 'pear info', at least that's what's the following message makes me guess:
pear info: tgz :: could not open file
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC