php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15406 Very strange include error
Submitted: 2002-02-06 15:57 UTC Modified: 2002-06-28 03:09 UTC
From: john at coggeshall dot org Assigned:
Status: Closed Package: Variables related
PHP Version: 4.1.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john at coggeshall dot org
New email:
PHP Version: OS:

 

 [2002-02-06 15:57 UTC] john at coggeshall dot org
I'm not sure how exactly this bug is being produced, but I'm almost positive it's not my code anymore. For some reason, include_once is giving me the following error:

An error (#2 - E_WARNING) has occured in file /home/httpd
/html/index.php (line 39) at Wed Feb 6 15:50:07 EST 2002: Unable to include '/we
bspace/basisadmin/dot.gi/?noheaders=1' - request execution failed

The problem is this 'dot.gi' part of the string -- it doesn't EVER exist as far as I can tell.. I've tried to echo the variable that stores the path just prior to the include_once call and echo it to the browser... it echos (correctly without this 'dot.gi') but the error still occurs. Instead of 'dot.gi' in the echo output, I get the correct '/home/httpd/html/webspace/basisadmin/index.php'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-07 06:44 UTC] sander@php.net
Can you provide a _self contained_ sample script?
 [2002-02-11 19:13 UTC] john at coggeshall dot org
There is a great deal of code involved before this bug happens, so I don't know if I can produce it in a self-contained script. However, I can tell you that there is, at no point in time in any way shape or form any string generated that is of the format "dot.gi"
 [2002-06-28 03:09 UTC] derick@php.net
Please reopen if you can provide a reproducing script, there is no way for us to debug this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 21 00:01:24 2020 UTC