php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15377 php.ini is not in right location
Submitted: 2002-02-05 00:00 UTC Modified: 2002-06-01 12:20 UTC
From: ericme at 21cn dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.1.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ericme at 21cn dot com
New email:
PHP Version: OS:

 

 [2002-02-05 00:00 UTC] ericme at 21cn dot com
First step, I installed a apache1.3.22 and php4.1.1 on my Linux(RH7.2). Then I packaged the two destination folder and moved them to a new Linux server. 
Then, I unpacked the binary package and modify the config files of apache. Now, my web server could be started, but when i use phpinfo() function, it showed that php.ini file is under /home/phpuser/php4/lib/php.ini. this is the folder under the first server, which I compiled php and apache. Now in the second server, the right folder should be:
/home/apacheuser/php/lib/php.ini Right?
I now that php4.0.5 will seek php.ini under /usr/local/lib,and this path exist on every machine. so I just need to do is copying the php.ini file into it. In fact, I think you guys are bright and make a greate progress to move php.ini under php/lib. After doing this, people can seek and modify php.ini under his/her own home folder and do not need to ask for some special privileges. I like this feature. 
The problem is, how can I change php.ini's location after installation? 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-01 12:20 UTC] edink@php.net
You can specify php.ini location with --with-config-file-path directive at compile time, or by setting PHPRC environmental variable at runtime.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 10:01:23 2020 UTC