php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #15343 Localization of PHP
Submitted: 2002-02-02 06:55 UTC Modified: 2002-02-02 12:41 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: daniel@php.net Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.1.1 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: daniel@php.net
New email:
PHP Version: OS:

 

 [2002-02-02 06:55 UTC] daniel@php.net
Until now PHP has used the $ prefix for variables what is clearly influenced by script languages such as Perl which have their roots in the USA.

As PHP's core components, such as ZEND, are developed in Europe and many opinion leaders are from here I'd suggest to replace $ by the Euro sign ? as of PHP5.

Yes, this will break some of the existing scripts, but we might provide a tool which replaces all occurencies of $ by ?.

-- 
  Daniel Lorch
  http://daniel.lorch.cc/

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-02 07:36 UTC] derick@php.net
:)

But your eurosign came out as ^A here

Derick
 [2002-02-02 08:01 UTC] chef at efton dot net
by the way, pressing the $ key is much easyier as to press the euro ? key. so why do that changing?

efton
http://www.efton.net
 [2002-02-02 08:11 UTC] daniel@php.net
Because it was meant to be a joke :)
 [2002-02-02 12:02 UTC] sebastian@php.net
Can't we just drop the $ and have variables without a prefix character?
 [2002-02-02 12:41 UTC] daniel@php.net
AFAIK the prepended $ makes it possible to parse faster - i.e. differentiating between variables and functions. Also, there would be a namespace problem ("is it a variable or a function?").
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 13:06:06 2022 UTC