|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15297 Corrupted html output
Submitted: 2002-01-30 06:30 UTC Modified: 2002-07-19 01:00 UTC
Avg. Score:3.0 ± 2.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: namela at v-share dot com Assigned:
Status: No Feedback Package: Scripting Engine problem
PHP Version: 4.1.1 OS: RedHat 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: namela at v-share dot com
New email:
PHP Version: OS:


 [2002-01-30 06:30 UTC] namela at v-share dot com
I 've tried upgrading to V4.1.1 after a succefull build i tried to fetch https pages, the behavior of php was realy strange, php didn't returned all the html code to the browser but insteand the html was corrupted after some output.
The problem was also reproduced with V4.1.0 after this problems i downgraded to V4.0.6 which seems to work just fine.
Please note that php didn't return any errors and that this problem was randomly reproduced, eg after the 5th,6th fetch on the same page php was generating the corrupted html while all the other fetched where succeded

System configuration
RedHat 7.2, kernel 2.4.7-10

PHP is build as a shared module, as a static link the results where the same


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-30 14:54 UTC]
Can you post your configure-line, and a short sample script?
Also, are you using zlib outputcompression and/or ouput buffering?
 [2002-01-31 01:28 UTC] namela at v-share dot com
'./configure' '--with-mysql=/usr/local' '--enable-track-vars' '--with-imap=../imap-2001a' '--with-gd' '--with-freetype-dir' '--with-ttf' '--with-curl' '--with-apxs=/usr/local/apache/bin/apxs'

please note that now i have upgraded apache to 1.3.20 thinking that the problem could be from apache for some reason but this didn't helped also.

As for the script.... do not think that i can post a sample script the script is for on-line ordering and there is a lot of scripts involved i also found an other post with the same problems on XP, the guy was claiming that the problems was occured from output buffering and that after set php ini 'implicit_flush=on' his problems solved..never had a change to try this

> Also, are you using zlib outputcompression and/or ouput buffering?
No, nothing like this i was using a ini file from php 3 in other words parameters regarding compression,buffering didn't exist in the ini file i hope that those variables are initialized to defaults (off)

 [2002-01-31 06:02 UTC]
Try using the php.ini-dist (copied over to php.ini) from
the PHP 4.1.1 distribution. There have been cases where
the problem has been an old php.ini file.


 [2002-01-31 06:53 UTC] namela at v-share dot com
It looks like this was the problem i entered default values from php.ini-dist to the old v3 ini file and till now i cannot reproduce the problem.
In other words php dosen't return defaults when loading an ini file ???
 [2002-01-31 06:57 UTC] namela at v-share dot com
Well....after some additional tests the problem appeared again, any other ideas ? 
The only difference with my php.ini and the php.ini-dist is the include directory and parsing of asp like tags would a dump of php.ini could help ?
 [2002-01-31 11:06 UTC] namela at v-share dot com
After a bug-report i show regarding the same problems ihave the poster was telling that if setting implicit_flush=on in php.ini then the problem is not reproducable. Well this is true in my case also, setting this option in php i cannot reproduce the problem.
Something that could make send is that the generated html file is 30,778 if this matters
 [2002-06-18 05:15 UTC]
Is this fixed or not? (if not, please try the latest version of PHP (4.2.1)).

 [2002-07-19 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 11:01:27 2024 UTC