php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15285 Wrong group when creating directories
Submitted: 2002-01-29 17:00 UTC Modified: 2002-01-30 12:51 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: tech at kalyweb dot com Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 4.1.0 OS: Linux RedHat 7.x
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tech at kalyweb dot com
New email:
PHP Version: OS:

 

 [2002-01-29 17:00 UTC] tech at kalyweb dot com
Here's a short script (the cause of the beginning) :
<?
  umask(000);
  mkdir("drawer/$newdir",0777);
?>

When this is done (this code is simplified) the file is owned by user nobody and group #-1 ...

Here's the configure line : 
'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--enable-inline-optimization' '--enable-debug=no' '--enable-safe-mode' '--enable-calendar' '--enable-sysvsem' '--enable-sysvshm' '--enable-trans-sid' '--disable-static' '--with-regex=system' '--with-mysql=/usr/local/mysql' '--with-freetype-dir=/usr' '--with-gd=/usr' '--enable-gd-native-tt' '--enable-freetype-4bit-antialias-hack' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-tiff-dir=/usr' '--with-zlib=/usr' '--with-pdflib=/usr'

I'm running Zend optimiser V1.2.0

This script was running as a module from Apache V1.3.20 (apache user : nobody, group : nobody).

I didn't test if this bug is also on other systems (I've only RedHat7.x servers, but only one that can run Apache, the others has their respective tasks).

I didn't compile PHP with the --enable-debug then I'm not able to give the gdb backtrace (?) ...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-30 12:51 UTC] sander@php.net
Usererror -> bogus
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jun 22 15:01:24 2021 UTC