php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15251 Cannot upload one file but two files
Submitted: 2002-01-28 03:42 UTC Modified: 2002-04-03 02:35 UTC
From: yohgaki@php.net Assigned:
Status: Closed Package: Output Control
PHP Version: 4.3.0-dev OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yohgaki@php.net
New email:
PHP Version: OS:

 

 [2002-01-28 03:42 UTC] yohgaki@php.net
Cannot upload one but files... with ZE1. Segfaults with ZE2 :(
(IE6.0 & W2K/ Mozilla 0.9.7+ & Linux)

======= begin =======
<html>
<head>
<title>File Upload Test</title>
<meta http-equiv="Content-Type" content="text/html; charset=EUC-JP">
</head>

<body bgcolor="#FFFFFF">
<pre>
$HTTP_POST_FILES

<?php
// Data about Uploaded Files are stored in array in $HTTP_POST_FILES["input_name"]
if (isset($HTTP_POST_FILES)) {
   print_r($HTTP_POST_FILES);
}

?>
</pre>  
<form enctype="multipart/form-data" action="file_upload.php" method="post">
<input type="text" name"text" value="TEST">
<input type="hidden" name="MAX_FILE_SIZE" value="100000000">
Send this file: <input type="file" name="userfile[]">
Send this file: <input type="file" name="userfile[]">
<input type="submit" value="Send File">
</form>
</body>
</html>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-04 07:39 UTC] sesser@php.net
$HTTP_POST_FILES["input_name"]
if (isset($HTTP_POST_FILES)) {
   print_r($HTTP_POST_FILES);
}

There is a missing ;

if i add it i see no effect without it i dont get any response (only headers) and the apache error log tells me that there is a parse error in line...

Shouldn't that parse error get printed to the http
stream?
 [2002-02-04 08:15 UTC] sesser@php.net
with no effect i mean: uploading one or two files worked without any problem.
 [2002-02-04 09:37 UTC] yohgaki@php.net
Hmm. That's strange. One thing I can think of is mbstring module, but mbstring module is designed not to convert multi-part form data....

I'll try w/o mbstring when I have time.

BTW, I didn't notice parse error. I'll check if it's logged, also.
 [2002-02-07 05:50 UTC] yohgaki@php.net
I tested again. It works for me now :)
I don't actually change configuration. I upgraded to apache 1.3.23/mod 2.8.6, though.
 [2002-02-07 05:52 UTC] yohgaki@php.net
Oops. Problem still exists :(
 [2002-02-07 07:17 UTC] sesser@php.net
Hmmm tjo,

you know the procedure...

1) Can you try it with IE5.5?
2) Is this exact the script you used? (remember the ;)
3) what is your config.nice (cause i wasnt able to reproduce) with my plain installation


 [2002-02-07 08:25 UTC] alindeman@php.net
Status -> Feedback
 [2002-02-07 20:10 UTC] yohgaki@php.net
I forgot to memtion apache error log with a single file upload

Unknown(0) : Warning - No file uploaded

BTW, I usually test both IE and Mozilla(Linux) latest.... 
The same result.....

Assign to me for now.
 [2002-02-27 07:47 UTC] derick@php.net
Can you provide me with script for me to reproduce it?

Derick
 [2002-02-28 05:28 UTC] yohgaki@php.net
Test with today's CVS source, the same result :(
BTW, sample script is missing ";", but you know it's a typo :)

This is actually a related to output buffering. reclassified as output control problem. I cannot upload one file only when zlib.compression is used.
(I haven't tried ob_gzhandler)
 [2002-04-03 02:34 UTC] yohgaki@php.net
I tried this but today.
It works regardless of zlib.output_compression settings.

 [2002-04-03 02:35 UTC] yohgaki@php.net
s/but/bug/

BTW, I tested with 4.2.0-dev.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 20:01:28 2020 UTC