php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15229 unable to load dynamic module
Submitted: 2002-01-25 17:23 UTC Modified: 2002-03-06 10:12 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: dev at myesys dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.1.1 OS: win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dev at myesys dot com
New email:
PHP Version: OS:

 

 [2002-01-25 17:23 UTC] dev at myesys dot com
Hi, 
   when I try to declare any .dll extension in php.ini on windows, PHP give the message. 

Unable to load dynamic library 'c:\PHP/php_gd.dll' - The specified procedure could not be found. in Unknown on line 0 

php_gd.dll is really in c:\PHP dir.
My php.ini is OK.

The same problems appears on 2 of my win2k machines.
Many others persons have the same problem without answers.
Maybe it's another destruction from the virus nimda.

Thanks

Jordi



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-26 16:29 UTC] dev at myesys dot com
Yes, they are and not corrupt.

in my c:\winnt\php.ini:
extension_dir="c:\PHP";
extension="php_gd.dll";

php_gd.dll is in c:\PHP

I have read that the function dl() does'nt work on IIS, I use IIS. dl() and the extensions declaration in php.ini seems to be almost the same, that maybe the same problem.

Thanks for helps
 [2002-03-06 08:47 UTC] sander@php.net
You should NEVER use single backslashes on Windows with PHP, use either a single slash or a double backslash.
Does that fix your problem?\

BTW: dl() doesn't work on multithreaded websevers (like IIS) so it has been disabled on them, and that has nothing to do extensions enabled via php.ini.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 22:01:28 2024 UTC