php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15224 openSSL and cURL results in Apache seg-faulting
Submitted: 2002-01-25 12:53 UTC Modified: 2003-02-13 12:37 UTC
Votes:4
Avg. Score:4.5 ± 0.5
Reproduced:4 of 4 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (25.0%)
From: josh dot howlett at bris dot ac dot uk Assigned:
Status: No Feedback Package: OpenSSL related
PHP Version: 4.1.1 OS: Linux RH 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: josh dot howlett at bris dot ac dot uk
New email:
PHP Version: OS:

 

 [2002-01-25 12:53 UTC] josh dot howlett at bris dot ac dot uk
I have compiled PHP-4.1.1 with:

./configure --with-apxs --with-pgsql --enable-sockets 
--with-openssl --without-mysql --with-curl

I have compiled cURL-7.9.3 with:

./configure
 and
./configure --with-ssl

Otherwise, I'm using the standard RH stuff.

I'm using the XML-PHP stuff (usefulinc.com) to perform 
XML-RPC over HTTPS.  The XML-RPC requires cURL for this. 
 I need the openssl in PHP for another application.

If I perform the XML-RPC request I get:

[Fri Jan 25 17:24:44 2002] [notice] child pid 11452 exit 
signal Segmentation fault (11)

However, if I compile PHP without openSSL support, the 
request works fine.

Hope someone can help :-)

josh.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-26 08:35 UTC] sander@php.net
Can you provide a sample script and a backtrace (see http://bugs.php.net/bugs-generating-backtrace.php)?
 [2002-01-26 14:32 UTC] lists+bugs dot php dot net at box dot cz
Same problem ...
w/ OpenSSL it goes down everytime.
(version 4.1.1 goes down just if the script uses PHP authentication, 4.0.6 gets 'crazy' after some time ... really stable environment :( )
Btw, IMHO it's not Apache/SSL/glibc/libs problem ...
I've tried many different configurations (various Apaches, various Unixes, various compilers, various libraries (freetype, ...), various PHP4 configs) past three days ...
still having the same problem.
30 mins ago I found it works if I disable OpenSSL (EAPI).
Uff ... I call this 'total waste of time'.

PS: The only common things in this case are: gd 1.8.4, PHP3 + PHP4 support (--enable-versioning), all as DSO. And no, removing PHP3 won't solve the problem, I've already tried that ... guess what happened?
 [2002-02-27 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-02-12 14:20 UTC] alan at pair dot com
FreeBSD 4.6-stable
PHP 4.2.2 --with-curl
curl --with-ssl
Apache 1.3.27 with SSL

To reproduce the bug:
* start apache
* send a HUP signal to apache's parent process (to restart it)

The server needn't serve any pages (php or otherwise).  Apache crashes while trying to reinitialize SSL.

Running the same version of everything, but curl compiled --without-ssl makes it work correctly: the apache parent kills off its children and spawns new ones.
 [2003-02-12 14:21 UTC] alan at pair dot com
More details:
This happens with curl 7.9.8 or 7.10.3.
OpenSSL 0.9.7 or a variety of flavors of 0.9.6.
 [2003-02-13 11:00 UTC] alan at pair dot com
> Please try using this CVS snapshot:
>
>  http://snaps.php.net/php4-STABLE-latest.tar.gz

I did this; no dice.

It seems to be dying inside SSL_CTX_ctrl (via SSL_CTX_set_options) when called from apache's ssl_init_ConfigureServer at this line:

SSL_CTX_set_options(ctx, SSL_OP_ALL);

This is the same behavior it had before.  Thanks.
 [2003-02-13 12:37 UTC] sniper@php.net
alan@pair.com: The original reporter of this bug doesn't
seem to be interested/does not care, so please open a new report about this.

 [2007-06-11 12:19 UTC] mk at netgroup dot dk
I am seeing a problem that is very similar to this one.

i am useing
apache2 -v
Server version: Apache/2.0.54
Server built:   Jul 28 2006 09:04:55php -v
PHP 5.1.6-1 (cli) (built: Sep  1 2006 13:52:26)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

running on Debian Sarge.

if i run the php script from the console, php -f <file> its okay.

when i run it through the browser, it crashes the apache child and spawns a new one.

Whats next?
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 09:01:23 2021 UTC