php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15075 non-breaking spaces are ignored
Submitted: 2002-01-16 17:14 UTC Modified: 2002-01-17 16:20 UTC
From: bcourtney at midwestiso dot org Assigned:
Status: Not a bug Package: URL related
PHP Version: 4.1.1 OS: Linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bcourtney at midwestiso dot org
New email:
PHP Version: OS:

 

 [2002-01-16 17:14 UTC] bcourtney at midwestiso dot org
Just updated PHP from 3.0 to 4.1 but now it won't recognize the non-breaking space ( ) in passing a value to a variable.

We are using this for a form and it enters the information into the form.  We need the   because our users use both Netscape and Internet Explorer.

This worked before but doesn't work now.

<A HREF ="../on_line_training_registration.html?course=How&nbsp;to&nbsp;Become&nbsp;a&nbsp;MISO&nbsp;Customer.&date=Oct.&nbsp;22,&nbsp;2001">To Register</A></TD>

course is one variable and date is another

Is there a reason that the non-breaking space would quit working.

Thanks for any help!



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-17 13:39 UTC] sander@php.net
Use &amp; instead of & in href's (see urlencode/urldecode).
 [2002-01-17 16:06 UTC] bcourtney at midwestiso dot org
The &amp; doesn't work - IE and Netscape both do not recognize it.  I tried &nbsp;  and   &amp;  and &ampnbsp;
Maybe there is something more that I need to do.

Since this is being used as part of a variable value in PHP there must be something else.  It worked before the upgrade.

Any ideas are welcome
 [2002-01-17 16:20 UTC] goba@php.net
& is used as a separator for variables in URLs. Treating &nbsp; as a space was a misfeature of PHP 3 if this
worked with it. & is a delimiter.

And this is not a php.net website problem at all.
This is an "URL related" problem.

--
Goba
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 18 13:03:38 2021 UTC