php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15056 rpm build problem: apxs capabilities misdetected
Submitted: 2002-01-15 16:12 UTC Modified: 2002-03-04 13:37 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: gerd at deam dot de Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 4.1.1 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gerd at deam dot de
New email:
PHP Version: OS:

 

 [2002-01-15 16:12 UTC] gerd at deam dot de
When I compile my self-created php rpm the configure 
script misdetects the capabilities of the installed apxs 
(speak: the -S option). That leads to files installed 
directly in /usr/lib/apache and not /var/tmp/php-root/...

I tracked it down and it looks like a bash incompatibilty 
(I'm using bash 2.04).

The attached patch fixes the problem for me.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-15 16:15 UTC] gerd at deam dot de
--- php-4.1.1/sapi/apache/config.m4     Mon Nov 19 
01:52:02 2001
+++ php-4.1.1.new/sapi/apache/config.m4 Tue Jan 15 
20:46:44 2002
@@ -41,7 +41,7 @@
   PHP_SAPI=apache

   # Test whether apxs support -S option
-  $APXS -q -S CFLAGS=$APXS_CFLAGS CFLAGS >/dev/null 2>&1
+  $APXS -q -S "CFLAGS=$APXS_CFLAGS" CFLAGS >/dev/null 2>&1

   if test "$?" != "0"; then
     APACHE_INSTALL="$APXS -i -a -n php4 $SAPI_SHARED" # 
Old apxs does not have -S option

(he guys, you should really add a "attach file" option to 
your bug reporting system like it is common in bugzilla...)

 [2002-03-04 13:37 UTC] sander@php.net
This bug has been fixed in CVS.

(dupe of #15572)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 04:05:54 2022 UTC