php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15033 Apache child procs segfault on AIX 5.1 with OCI8
Submitted: 2002-01-14 14:37 UTC Modified: 2002-03-08 13:54 UTC
From: david-shafer at uiowa dot edu Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.1.1 OS: AIX 5.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: david-shafer at uiowa dot edu
New email:
PHP Version: OS:

 

 [2002-01-14 14:37 UTC] david-shafer at uiowa dot edu
When I compile PHP 4.1.1 with OCI8 support and try to run it on a system with AIX 5.1, the Apache child processes generate segfaults until I stop Apache. The behavior has been observed on two different AIX 5.1 systems, and it happens regardless of whether PHP was compiled on an AIX 4.3 or 5.1 system.

The Oracle client libraries are properly installed, and Oracle utilities like "sqlplus" run normally.

If I remove OCI8 support from the PHP module, or if I run the same module with OCI8 support on an AIX 4.3 system, it works just fine.

Here's the environment:

AIX 5.1
PHP 4.1.1
Oracle 8.1.7 client libraries
IBM VisualAge C 5.0.1

export CC="cc_r"
export CFLAGS="-g -ma"

./configure --prefix=/local/www/php \
--with-apxs=/local/www/bin/apxs \
--with-config-file-path=/local/www/php \
--without-mysql \
--with-oci8=/ora00/app/oracle/product/8.1.7

Here's how I reproduce the problem:

# make install
# /local/www/bin/apachectl start
# tail -f /local/www/logs/www.err

[Wed Jan  9 13:33:05 2002] [notice] Apache/1.3.20 (Unix) PHP/4.1.1 configured --
 resuming normal operations
[Wed Jan  9 13:33:06 2002] [notice] child pid 13720 exit signal Illegal instruct
ion (4)
[Wed Jan  9 13:33:06 2002] [notice] child pid 14672 exit signal Illegal instruct
ion (4)
[Wed Jan  9 13:33:06 2002] [notice] child pid 5884 exit signal Illegal instructi
on (4)
[Wed Jan  9 13:33:06 2002] [notice] child pid 17438 exit signal Illegal instruct
ion (4)
[Wed Jan  9 13:33:06 2002] [notice] child pid 16608 exit signal Illegal instruct
ion (4)
[Wed Jan  9 13:33:08 2002] [notice] child pid 17440 exit signal Illegal instruct
ion (4)
[Wed Jan  9 13:33:09 2002] [notice] child pid 14674 exit signal Illegal instruct
ion (4)
[Wed Jan  9 13:33:09 2002] [notice] child pid 5886 exit signal Illegal instructi
on (4)
...

# /local/www/bin/apachectl stop

# /local/www/bin/httpd -X
{accepts vanilla html requests, sometimes doesn't terminate on ^C until after it's received a request}

If I try to access a simple script ("<?php print "Hello"; ?>") while running with "-X", I get the following output:

Warning: Failed opening '/local/www/vhosts/owl.its.uiowa.edu/docs/phpinfo.php' for inclusion (include_path='') in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-14 17:12 UTC] david-shafer at uiowa dot edu
Disregard the previous "httpd -X" test case; the error message was caused by another problem. The child segfault problem still stands, however.
 [2002-03-08 13:54 UTC] david-shafer at uiowa dot edu
Installing AIX patches resolved the problem.

The system had been at AIX 5.1 Maintenance Level 1. The following filesets were among those patched more recently than ML 1, and were potentially responsible for resolving the problem:

5.1.0.15 bos.64bit
5.1.0.15 bos.mp64
5.1.0.15 bos.mp
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Dec 03 02:05:54 2022 UTC