php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15016 is_dir, is_file
Submitted: 2002-01-13 12:35 UTC Modified: 2002-02-13 15:18 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: bpang at bpang dot com Assigned:
Status: Closed Package: Strings related
PHP Version: 4.1.1 OS: RedHat 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bpang at bpang dot com
New email:
PHP Version: OS:

 

 [2002-01-13 12:35 UTC] bpang at bpang dot com
I also posted this as a note in the is_dir function reference.
Configure Command: './configure' '--with-mysql' '--with-apxs'

This (is_dir) no longer seems to work properly, nor is_file as of 4.1.1 on RedHat 7.0 with Apache 1.3.22.
When is_dir is attempted, files are returned true as well.
My workaround has been to attempt to open each $file returned from the readdir() using @opendir (with @ to suppress errors).
If @opendir($file) returns true, I know it's a dir, otherwise, must be a file (or a link).
Perhaps there is something wrong with my config, but then again, maybe something changed?
is_dir used to work for me in 4.0.4

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-10 15:39 UTC] elixer@php.net
Could you please supply a short (self-contained) reproducing script?

Sean
 [2002-02-10 15:39 UTC] elixer@php.net
Open -> Feedback
 [2002-02-13 15:18 UTC] bpang at bpang dot com
wouldn't ya know it! I can't reproduce it now

go figure

sorry, dang, really... it didn't work before.. I'll repost if I can make it happen again.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Dec 05 16:01:29 2023 UTC