php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15007 New superglobals not documented
Submitted: 2002-01-12 15:33 UTC Modified: 2002-08-23 22:11 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: fredk at L5Software dot com Assigned:
Status: Wont fix Package: Website problem
PHP Version: 4.1.1 OS: N/A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fredk at L5Software dot com
New email:
PHP Version: OS:

 

 [2002-01-12 15:33 UTC] fredk at L5Software dot com
I've seen the new "$_SERVER" (for example) variable arrays mentioned, as replacements for the old $HTTP_SERVER_VARS (I think) array, but I wasn't able to easily find any pages that mention them.  I therefore put $_SERVER (no quotes) in the search box, and got pages with the word "server", not "$_SERVER" so I tried entering "$_SERVER" (a quoted string), which produced the same results.

Problems:
1.  It appears there is no way to find pages with the exact text $_SERVER using this search system.
2.  Discussion of $_SERVER (and $POST, $_ENV, etc.) arrays needs to be findable in the documentation.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-12 16:35 UTC] imajes@php.net
yes, we are aware of this, and documentation people are working on documentation for _* global variables.

Thanks.
 [2002-01-12 16:46 UTC] fredk at L5Software dot com
I appreciate you're working on the _* documentation, but the problem remains there is no way to search for "$_SERVER" and get results that contain the exact string
 [2002-01-12 16:55 UTC] mfischer@php.net
Reclassified, reopened.
 [2002-01-12 17:09 UTC] philip@php.net
This appears to be a website problem, not a documentation problem.  Searching for '$_SERVER' results in matches for 'server', over 2000 of them.  If this was a documentation problem, zero results would exist.

This is a website problem/feature request.
 [2002-01-13 06:25 UTC] goba@php.net
Please use "_SERVER" as your search term. $ may be special
for htdig.
 [2002-01-15 07:15 UTC] sander@php.net
Dupe of #14378
 [2002-01-15 13:44 UTC] philip@php.net
The _ in "_SERVER" get's ignored.  _SERVER_ is the same, 553 of unrelated results (I swear it was 2000 before :).  HTTP_SERVER_VARS works fine.  Someone here knows htdig, maybe can adjust?

I assume $_SERVER is somewhere in the online manual user comments.  The info in the manual CVS now but the manual has some build difficulties currently.  Regardless, _SERVER != SERVER.  Maybe making such an adjustment will cause other problems?

This is a duplicate, in that imho it's a feature request to add custom "go" words to the search mechanism.  Ideally, we can create a list of words and where they should point to in manual upon the search.  Working with a list of popular searches will be helpful too.
 [2002-08-23 22:11 UTC] sniper@php.net
The other bug was marked as 'Wont fix' so..

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Oct 14 17:01:27 2019 UTC