php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14979 Uploads on Windows XP with apache do not upload
Submitted: 2002-01-10 16:38 UTC Modified: 2002-01-10 17:28 UTC
From: rabbitdog at inter-tek dot net Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.1.1 OS: Windows XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rabbitdog at inter-tek dot net
New email:
PHP Version: OS:

 

 [2002-01-10 16:38 UTC] rabbitdog at inter-tek dot net
Uploaded files from forms do not appear in the defined temporary directory; however, PHP acts as if it was uploaded fine, even assigns a temporary name
to it:

Array ( [file] => Array ( [name] => headline.gif [type] => image/gif
[tmp_name] => C:\Apache\php\uploadtemp\php102D.tmp [size] => 17936 ) )

The problem is, no such file exists in C:\Apache\php\uploadtemp\.

My temporary directory is specified like this in the PHP.ini:

upload_tmp_dir = C:\Apache\php\uploadtemp\

I have also tried upload_tmp_dir = C:\Apache\php\uploadtemp

and not setting a temporary directory at all to force php to use the system default. 

There is nothing spectacular about my setup, its simply Apache with PHP running as a module.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-16 02:55 UTC] jdroberts at carolina dot rr dot com
agreed. server info: winXPpro,PHP.v4.3.2,apache.v2.0.47 --

i've configured php with apache as a CGI and module, both to no avail.  Also reverted back to apache.v1.2.37 with the same results.  I modified the tmp directory to anywhere you can think of and gave EVERYONE rights to full control of the tmp directory.  PHP reports all info about the file, and even the file location correctly; however, the file is never written to that location.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jul 01 14:05:46 2022 UTC