|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14881 Apache fails to start after PHP compile
Submitted: 2002-01-05 21:56 UTC Modified: 2002-06-07 18:29 UTC
Avg. Score:4.0 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:1 (33.3%)
From: dw59 at earthlink dot net Assigned:
Status: Closed Package: GD related
PHP Version: 4.1.1 OS: Cobalt (Red Hat) Linux 6.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: dw59 at earthlink dot net
New email:
PHP Version: OS:


 [2002-01-05 21:56 UTC] dw59 at earthlink dot net
After compile of PHP 4.1.1 Apache failed to start with the following warning:

/etc/rc.d/init.d/httpd start 
Setting up Web Service: Syntax error on line 58 of
Cannot load /etc/httpd/modules/ into server:
/etc/httpd/modules/ undefined symbol: gdImageColorResolve

Configure line:

./configure --prefix=/usr --with-mysql --with-apxs=/usr/sbin/apxs --with-gd --with-gettext=/usr --enable-safe-mode --with-config-file-path=/etc/httpd --with-exec-dir=/usr/bin --with-zlib --enable-magic-quotes --with-regex=system --with-ttf=/usr/lib/ --enable-track-vars --enable-xml --disable-debug --with-db --with-interbase=shared --with-pgsql=shared --with-ldap --with-imap

I removed --with-gd and everything worked fine.  Possible due to GD compatability?  PHP 4.0.6 compiled OK with same gd library currently installed on system.

Dennis Williams


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-07 16:58 UTC] dw59 at earthlink dot net
This issue has apparently been corrected by a suggestion from another user...their suggestion worked for my recompile on 4.2.1:

I had the same problem getting Apache to start after compiling 4.1.2. I then found this snippet: in file php-4.1.2/ext/gd/php_gd.h find near line 66 the following: 


static int gdImageColorResolve(gdImagePtr, int, int, int); 

then change the static to extern so the line now reads: 

extern int gdImageColorResolve(gdImagePtr, int, int, int); 

then recompile.

Thanks to Mark who posted on

Dennis Williams
 [2002-06-07 18:29 UTC]
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at In case this was a documentation 
problem, the fix will show up soon at
In case this was a website problem, the change will show
up on the site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 15 10:01:27 2024 UTC