php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14881 Apache fails to start after PHP compile
Submitted: 2002-01-05 21:56 UTC Modified: 2002-06-07 18:29 UTC
Votes:3
Avg. Score:4.0 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:1 (33.3%)
From: dw59 at earthlink dot net Assigned:
Status: Closed Package: GD related
PHP Version: 4.1.1 OS: Cobalt (Red Hat) Linux 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dw59 at earthlink dot net
New email:
PHP Version: OS:

 

 [2002-01-05 21:56 UTC] dw59 at earthlink dot net
After compile of PHP 4.1.1 Apache failed to start with the following warning:

/etc/rc.d/init.d/httpd start 
Setting up Web Service: Syntax error on line 58 of
/etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server:
/etc/httpd/modules/libphp4.so: undefined symbol: gdImageColorResolve
/usr/sbin/httpd

Configure line:

./configure --prefix=/usr --with-mysql --with-apxs=/usr/sbin/apxs --with-gd --with-gettext=/usr --enable-safe-mode --with-config-file-path=/etc/httpd --with-exec-dir=/usr/bin --with-zlib --enable-magic-quotes --with-regex=system --with-ttf=/usr/lib/libttf.so --enable-track-vars --enable-xml --disable-debug --with-db --with-interbase=shared --with-pgsql=shared --with-ldap --with-imap

I removed --with-gd and everything worked fine.  Possible due to GD compatability?  PHP 4.0.6 compiled OK with same gd library currently installed on system.

Thanks,
Dennis Williams

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-07 16:58 UTC] dw59 at earthlink dot net
This issue has apparently been corrected by a suggestion from another user...their suggestion worked for my recompile on 4.2.1:

I had the same problem getting Apache to start after compiling 4.1.2. I then found this snippet: in file php-4.1.2/ext/gd/php_gd.h find near line 66 the following: 

PHP_MSHUTDOWN_FUNCTION(gd); 

#ifndef HAVE_GDIMAGECOLORRESOLVE 
static int gdImageColorResolve(gdImagePtr, int, int, int); 
#endif 

then change the static to extern so the line now reads: 

extern int gdImageColorResolve(gdImagePtr, int, int, int); 

then recompile.

Thanks to Mark who posted on http://i4net.tv/...

mailto:mark@NO_SPamThanks.logictotal.freeserve.co.uk


Thanks,
Dennis Williams
 [2002-06-07 18:29 UTC] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 23 19:01:25 2021 UTC