php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14868 incorrect configuration for --with-java
Submitted: 2002-01-05 05:48 UTC Modified: 2002-08-14 12:12 UTC
From: phil at bolthole dot com Assigned:
Status: Closed Package: Java related
PHP Version: 4.1.0 OS: solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: phil at bolthole dot com
New email:
PHP Version: OS:

 

 [2002-01-05 05:48 UTC] phil at bolthole dot com
There are MULTIPLE problems with what should be a simple
option for configure:

 --with-java=/usr/java1.1

Problem #1: improper detection of javac and jar in PATH.
 I had JAVA_JAR set to "no jar in /usr/bin ....."
 Please check to see that there is an actual executable!
Similar problem with javac. 
  ext/java/Makefile hardcodes 'javac', instead of having
  a variable $(JAVAC) set in config_vars.mk, and having
  an executable check done for the var.
[adding /usr/java1.1/bin to my PATH solves both problems]

Additional problem: 
JAVA_INCLUDE =  -I/usr/java1.1/include

is not adequate. It must be

JAVA_INCLUDE = -I/usr/java1.1/include/solaris \   -I/usr/java1.1/include

because jni_md.h is in the solaris subdir.


Once I hand-edited the above valies in config_vars.mk,
the java extention compile successfully with solaris 8.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-08 10:04 UTC] kalowsky@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.


 [2002-08-12 23:47 UTC] kennyz at nycap dot rr dot com
I just checked out the latest snapshot (200208121800), and this is not fixed.  The $JAVA_HOME/include directory does NOT contain jni_md.h.  It is in a machine-specific subdirectory, such as $JAVA_HOME/include/linux/jni_md.h or $JAVA_HOME/include/solaris/jni_md.h.

My quick fix is to create a symbolic link in $JAVA_HOME/include that points to $JAVA_HOME/include/linux/jni_md.h, but this is a direct modification of the Java distribution, and should not be done.  Therefore, the PHP4 configure scripts must be fixed.
 [2002-08-13 08:33 UTC] kalowsky@php.net
setting back to open until it's fixed.
 [2002-08-14 12:12 UTC] kalowsky@php.net
Please try a CVS version of this, as I believe this is now fixed.  CVS meaning non-STABLE builds.  
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 00:03:49 2021 UTC