php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14865 php4apache.dll - phpinfo error - winXP - Apache
Submitted: 2002-01-04 20:51 UTC Modified: 2002-07-13 01:00 UTC
Votes:25
Avg. Score:4.6 ± 0.8
Reproduced:22 of 23 (95.7%)
Same Version:11 (50.0%)
Same OS:22 (100.0%)
From: p dot wenger at gmx dot ch Assigned:
Status: No Feedback Package: Apache related
PHP Version: 4.1.1 and 4.2.1 OS: Win XP Prof
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: p dot wenger at gmx dot ch
New email:
PHP Version: OS:

 

 [2002-01-04 20:51 UTC] p dot wenger at gmx dot ch
I have problem with the php4apache.dll on win xp prof apache 1.3.22 and php4.1.1 !

Server API: Apache
If you execute the phpinfo(), same time it work, but the most time came the message that the page not can show. Or same line are wrong (wrong character like @#??@?@#?879...)
http://xp.wenpas.ch:8080/phpinfo.php4c


Server API: CGI
The same example with the installation as CGI work fine. (same php.ini)
http://xp.wenpas.ch:8080/phpinfo.php4a

I think the problem is at php4apache.dll

Pascal

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-06 07:05 UTC] p dot wenger at gmx dot ch
Here are the part which you need:

    LoadModule php4_module c:/php/sapi/php4apache.dll
    AddType application/x-httpd-php .php4a



   ScriptAlias /php3/ "c:/php3/"
   AddType application/x-httpd-php3 .php3
   Action application/x-httpd-php3 "/php3/php.exe"

   ScriptAlias /php/ "c:/php/"
   AddType application/x-httpd-php4 .php
   AddType application/x-httpd-php4 .php4
   AddType application/x-httpd-php4 .php4c
   Action application/x-httpd-php4 "/php/php.exe"
//-----------------------------------------------

I did a easy example, that works with both API's!
<?php
echo "bla";
?>
http://www.wenpas.ch:8080/bla.php4c
http://www.wenpas.ch:8080/bla.php4a

And here  the other example:
<?php
	phpinfo();
?>
http://www.wenpas.ch:8080/phpinfo.php4a
http://www.wenpas.ch:8080/phpinfo.php4c
http://www.wenpas.ch:8080/phpinfo.php3
http://www.wenpas.ch:8080/phpinfo.php4
http://www.wenpas.ch:8080/phpinfo.php

The ends .php4a and .php4c are only for you to testing.
c = cgi
a = apache (php4apache.dll)




 [2002-05-31 02:45 UTC] p dot wenger at gmx dot ch
The Problem is not solved!
I yesterday install the new version 4.2.1 on my WinXP, but the Problem is hier again!
phpinfo() don't work fine! And same websites with mysql work only fine when I browse the Site from local! But from extern I recive output with same wrong characters like x-  `wH?   ????h'!
CGI-Installtion work fine!
 [2002-06-01 09:11 UTC] sniper@php.net
When you updated, did you also update the php4ts.dll ??
And are you sure you only have ONE of those in your system?

 [2002-06-04 05:19 UTC] p dot wenger at gmx dot ch
Yes I only have one and the right 'dll'!
 [2002-06-04 08:28 UTC] sniper@php.net
To reduce the points where it might be breaking, could
you try and comment out all the extensions you're loading
in php.ini ? (and of course stop/start Apache again)

 [2002-06-12 04:18 UTC] p dot wenger at gmx dot ch
is this Bug-Report ( http://bugs.php.net/bug.php?id=16698 )
the same Problem as I have?

then the Problem is by Microsoft!
see:
http://www.apache.org/dist/httpd/binaries/win32/#xpbug
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q317949

I try anyway in the next days to config the server with the original config-File and only the minimum of changes for PHP?
 [2002-06-12 09:04 UTC] sniper@php.net
Did you try that fix from Microsoft? And what about the
latest non-stable snapshot of PHP?

 [2002-07-13 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-07-19 23:24 UTC] nallmj1 at wfu dot edu
This is not a PHP or Apache error, or at least not completely. It seems that MSIE is the main source of the problem. I am experiencing similar problems with MSIE6 (in Windows XP) but no problems at all with Netscape 6.2. I am using PHP 4.2.2 and Apache 2.0.39, which I also used on my old Windows 2000 machine; it never gave me any trouble even though I also had MSIE6 on it.

I tested http://mvirtue.myip.org/test/index.php posted by mvirtue@zip.com.au [22 Mar 12:24am], and it produces the same errors in MSIE but works flawlessly in Netscape.

Because I prefer MSIE as most people do, I would like to know if anyone has the updated AFD.SYS file mentioned in http://support.microsoft.com/default.aspx?scid=kb;EN-US;q317949 because Microsoft does not offer it freely for some reason. Seeing as this problem occurs only in MSIE6 and only with WinXP I think that update could solve the IE problem.

Thanks,
Matt
 [2003-03-15 19:28 UTC] kensl at csie dot nctu dot edu dot tw
Download Windows XP Service pack 1a
http://www.microsoft.com/windowsxp/pro/downloads/servicepacks/sp1/default.asp
It works!
 [2004-07-24 17:50 UTC] jeremy at chezwallis dot com
Hi,

I experienced the same problem today with :
- Apache 2.0.50 (win32) and
- PHP 4.3.4
- Windows XP SP1 + all critical updates

I got desperate and eventually changed the httpd.conf file entry where you specify the Load Module line :

- Instead of using php4apache.dll

... I noticed that there is another similar file in the folder called php4apache2.dll.

So I edited my line to read :
LoadModule php4_module "c:/program files/php/sapi/php4apache2.dll"

... and now Apache starts correctly and PHP works perfectly.

Not sure if I did something wrong in this but it works so I am smiling (for now ?)

Cheers,

Jeremy.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 14:01:26 2018 UTC