php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14863 When using the gmDate() function, the time/date is 8 hours ahead
Submitted: 2002-01-04 20:10 UTC Modified: 2002-01-05 11:32 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: bryannisperos at hotmail dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.1.1 OS: Win2k Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bryannisperos at hotmail dot com
New email:
PHP Version: OS:

 

 [2002-01-04 20:10 UTC] bryannisperos at hotmail dot com
Problem:
When using the gmDate() function, the time/date is 8 hours ahead of the system clock.

Script: 
The date is <?php echo gmDate("l, M d Y, h i a"); ?>

Result:
The date is Saturday, Jan 05 2002, 01 06 am

Should have been:
The date is Friday, Jan 04 2002, 05 06 pm





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-05 11:32 UTC] derick@php.net
Ofcouurse it does. I expect that your timezone differs 8 houurs from GMT. And gmdate shows the time in GMT.

Not a bug,
Derick
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC