php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14808 "mm" module for session saving uses hardcoded path
Submitted: 2002-01-02 16:16 UTC Modified: 2002-01-10 01:18 UTC
From: hps at intermeta dot de Assigned: yohgaki (profile)
Status: Closed Package: Session related
PHP Version: 4.0CVS-2002-01-02 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hps at intermeta dot de
New email:
PHP Version: OS:

 

 [2002-01-02 16:16 UTC] hps at intermeta dot de
The session saving module in ext/session uses a hardcoded
path for its session file (/tmp/mm_session). This is bad
in environments where lots of php interpreters run in 
different webservers and User IDs (and different php.ini)
files. the attached patch fixes this problem and uses
session.save_path for this file.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-02 17:40 UTC] yohgaki@php.net
Thanks for reporting, but it's duplicate of other report.
Please search bug db :)

I'm working with external session save handler issue. I might fix this.
Your ptach fix one of the mm issue, but it still causes a problem under some configuration. I'll fix both, when I have time to do. 
 [2002-01-10 01:18 UTC] yohgaki@php.net
I applied  your patch for both 4.2.0-dev and 4.1.2-dev source. Thank you.

Issue left is PHP still have problem when multiple instance of PHP is trying to use the same file ;)

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon Jan 30 14:05:53 2023 UTC