php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14653 Internet Explorer for Macintosh receives bad HTTP header info from PHP Header()
Submitted: 2001-12-21 19:05 UTC Modified: 2001-12-22 04:16 UTC
From: fredb86 at hotmail dot com Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.0.6 OS: Free-BSD 4.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
42 - 3 = ?
Subscribe to this entry?

 
 [2001-12-21 19:05 UTC] fredb86 at hotmail dot com
The PHP Header() function isn't passing the correct HTTP redirect info to Internet Explorer 5.x for Macintosh.

program index.php:

<?php

Header("Location: http://www.mywebsite.com/junk.zip");

?>

----------

When this program is executed from Internet Explorer 5.0 or 5.1 for Macintosh, the file junk.zip will download correctly but it will be given the name index.php instead of junk.zip

--Fredb



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-22 04:16 UTC] sander@php.net
Not a bug in PHP. Microsoft is just not able to write proper software.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jul 25 01:01:24 2021 UTC