php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14622 Broken SERVER_SIGNATURE
Submitted: 2001-12-20 10:12 UTC Modified: 2001-12-22 15:12 UTC
From: darren dot shukri at conchango dot com Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.1.0 OS: Linux knl2.4 and Win2K Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: darren dot shukri at conchango dot com
New email:
PHP Version: OS:

 

 [2001-12-20 10:12 UTC] darren dot shukri at conchango dot com
Both $SERVER_SIGNATURE and $HTTP_SERVER_VARS["SERVER_SIGNATURE"] return a malformed result when Apache 1.3.2 has ServerSignature directive set to  EMail.

phpinfo returns the correct result under the heading "Apache Environment" but the malformed one under "PHP Variables".

The malformed result for my installation is:

<ADDRESS>Apache-AdvancedExtranetServer/1.3.20 Server at <A HREF=\"mailto:root@localhost\">gabriel.conchango.com</A> Port 80</ADDRESS>

The problem seems to be that the \ characters are not being interpolated and are thus corrupting the mailto: link in the resulting HTML page-source.

I suspect (although I have not tested) that the same problem would occur under other OSs/WebServers that use a server signature.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-22 15:12 UTC] sander@php.net
Not a bug. Check your magic quotes settings.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 09:03:33 2022 UTC