php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1462 Ora_connect fails with a error stating that I have given a "null-password"
Submitted: 1999-05-27 19:35 UTC Modified: 1999-05-29 11:44 UTC
From: fredrik dot rovik at sas dot no Assigned:
Status: Closed Package: Oracle related
PHP Version: 3.0.8 OS: Linux Redhat 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fredrik dot rovik at sas dot no
New email:
PHP Version: OS:

 

 [1999-05-27 19:35 UTC] fredrik dot rovik at sas dot no
I have some problems connecting to oracle using
the php 3.0.8 sourcetree (3.0.7 works fine).
I get an error stating I have not given a password or given a nullpassword, which ofcourse
is not the case.

As for compile options this is a DSO running under apache 1.3.6. compiled with the
following options --with-mysql=/usr/local --with-oracle --apxs=whatever.

Oracle client software is freshly installed from oracles website. Version 8.0.5.

<?
putenv("ORACLE_HOME=/usr/oracle/app/oracle/product/8.0.5");
putenv("ORACLE_SID=POBP");
putenv("TNS_ADMIN=/usr/oracle/tns");
putenv("PATH=/usr/oracle/app/oracle/product/8.0.5/bin:/usr/local/bin:/bin");
putenv("TNS_ADMIN=/usr/oracle/tns");
putenv("PATH=/usr/oracle/app/oracle/product/8.0.5/bin:/usr/local/bin:/bin");
$conn_id=ora_logon("jalla@whatever","whatever secret");
?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-05-29 11:44 UTC] thies at cvs dot php dot net
please do:

$con = ora_logon("user/pw@service","");


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jan 23 15:01:23 2021 UTC