php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14598 Exception Error using ISAPI Version
Submitted: 2001-12-19 05:43 UTC Modified: 2002-06-03 12:20 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jon5haw at hotmail dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.1.0 OS: NT4 SP6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jon5haw at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-12-19 05:43 UTC] jon5haw at hotmail dot com
Upgraded from 4.0.6 to 4.1.0, initially to CGI version.

Tried ISAPI version, but didn't last long - had following error message:-

The HTTP server encountered an unhandled exception while processing the ISAPI Application '
php4ts!zend_hash_add_or_update + 0xAB'.

NT4, SP6, 512MB Ram, dual processor, IIS4.
Zend Optimizer v1.2.0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-19 05:45 UTC] derick@php.net
Do you possibly use any old extension modules? Or can you make a stack dump (in VC++ if you have that installed)?
Does it happens on startup? If no, what is your script?
 [2001-12-19 11:52 UTC] jon5haw at hotmail dot com
There aren't any old extensions in use.  The only additional one that may get used is php_gd.  

Unfortunately, because this is our live intranet server, I can't do too much tesing (Cardiff County Council with 2000+ PC's). I wasn't able to get a stack dump.

The Upgrade and ISAPI version was working at 5.30 pm (and a noticeable speed improvement).  It crashed at 8.06 am, not long after people started work.  I wouldn't know what script caused the crash, as the whole intranet frontend is php/mysql.

Sorry I can't give you much info, but I'll try and get some more testing on our test server.


 [2001-12-19 12:05 UTC] derick@php.net
You can't use old modules from 4.0.6, but that doesn't seem the problem here. My best guess is that it crashed because GD is not totally threadsafe:

http://uk.php.net/manual/en/faq.obtaining.php


It would be nice if you could try it without GD....

regards,
Derick
 [2002-06-03 12:20 UTC] mfischer@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon Mar 27 09:03:37 2023 UTC