php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14556 PHP 4.1.0 and Apache 2.0.28 Beta incompatible statically and as DSO
Submitted: 2001-12-17 00:44 UTC Modified: 2002-02-25 06:23 UTC
Votes:13
Avg. Score:4.5 ± 0.9
Reproduced:12 of 12 (100.0%)
Same Version:4 (33.3%)
Same OS:8 (66.7%)
From: melt284 at hotmail dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.1.0 OS: RedHat Linux 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: melt284 at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-12-17 00:44 UTC] melt284 at hotmail dot com
When Trying to install PHP 4.1.0 as a DSO on Apache 2.0.28 Beta the install completes without errors. I use this ./configure line with PHP:

./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-track-vars

My httpd.conf contains the correct AddType and LoadModule lines and the module does exist in the directory LoadModule points to. My php.ini file is in /usr/local/lib

Apache starts fine but when when trying to view a PHP page the browser simply tries to donwload the file instead of show it in the browser.

If I try to compile PHP statically instead of as a DSO I use this ./configure line:

./configure --with-apache=/root/downloads/httpd-2_0_28/ --enable-track-vars

And recieve this:
configure: error: Invalid Apache directory - unable to find httpd.h under /root/downloads/httpd-2_0_28/

However httpd.h is there (in /root/downloads/httpd-2_0_28/includes/). Even if I change the ./configure line to say "includes/" at the end it still won't find the file.

Apache2 was compiled with so enabled.

If there is any other information I can provide please email me.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-12 08:58 UTC] rod at sunsetsystems dot com
Same problem here but with PHP 4.1.1 and Apache snapshot
2.0_20011228171212.
-- Rod
 [2002-01-15 13:57 UTC] miro1 at 000 dot sk
The same problem - to link php4.1.1 to Apache 2.0.28 statically.

There are bad checks in "Apache 2.0.x" section of "configure" script. Apache 2 distribution use another dirs as it used to be in Apache 1.3.x. I edited the "configure" script to correct the paths. Then it was running nice. I still have a problem with a compilation, "NOT_DEFINED" variable is missing in the part /sapi/apache, but I hope it will go soon.

Miro
 [2002-02-25 02:22 UTC] junk-php at aontic dot com
Seeing much the same thing, this looks like it has been an ongoing problem for 2 months or so. 

Using latest CVS snapshot

[php4-200202242100]# ./configure --with-apache=../httpd-2.0.32 
Configuring SAPI modules checking for AOLserver support... no 
checking for Apache module support via DSO through APXS... no 
checking for Apache module support... no
configure: error: Invalid Apache directory - unable to find httpd.h under /root/httpd-2.0.32

This is on a clean install of RedHat 7.2 2.4.9-21smp.

Think this looks like it is clearly on the php side of things, as the apache folks are pretty much API frozen going towards their GA release.
 [2002-02-25 06:23 UTC] yohgaki@php.net
Use 2.0.31 as documented.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 00:03:37 2021 UTC