php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14518 --enable-trans-id doesn't work
Submitted: 2001-12-14 11:35 UTC Modified: 2001-12-16 17:40 UTC
From: theseer@php.net Assigned:
Status: Closed Package: Session related
PHP Version: 4.1.0 OS: LInux 2.4.16 (RH7.2 based)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: theseer@php.net
New email:
PHP Version: OS:

 

 [2001-12-14 11:35 UTC] theseer@php.net
I compiled php4.1.0 with --enable-trans-id, configured to use no cookies for sessions.

Verifiying with phpinfo() shows the correct settings for cookies and enable-trans-id but php fails to add the session-id to any tag.

Passing a session-id manually works though.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-14 12:48 UTC] yohgaki@php.net
I suppose you've verified problem ;) Type = Critical

 [2001-12-14 20:38 UTC] sniper@php.net
Just note: I can not reproduce this with latest CVS.

 [2001-12-15 11:46 UTC] zeev@php.net
Can anybody else reproduce this on *4.1.0*?

 [2001-12-15 12:05 UTC] cmk@php.net
I can not reproduce this with 4.1.0
 [2001-12-15 21:52 UTC] yohgaki@php.net
theseer, do you use ob_end_*() in your script?
Could you add more details?

-- Yasuo
 [2001-12-16 12:04 UTC] theseer@php.net
I developed my stuff using the cvs-version and downgraded my workstation to 4.1.0 Release-Version to verify my code will be working on the live server...
[ glad, i did that though ;-) ]

To simplify and verify that it's not a stupid bug in my code, i did a simple testcode that works fine on my 4.2.0-dev system, but doesn't work on any 4.1.0 i tried it with.

You can have a look for yourself:

 http://sugar.freepoint.de/session/

the index.php ( source as index.phps ) will start a session and setup one simple var with a value.

The link displayed should have a SESSION-ID as a parameter since php is not configured to use cookies ( verify by /session/info.php ) and to use trans-id's.

The logical result is that following the link will not have a session thus no value ( page2.php / page2.phps )

Again this code works with cvs on my workstation - my code beeing unchanged. Due to the use of $_SESSION it won't work with older versions of course..


 [2001-12-16 13:00 UTC] theseer@php.net
Found the reason:

the cvs-version doesn't seem to support or even care about --enable-trans-sid  where the 4.1.0 needs/uses the switch. I had a typo ( same as in the summary, dropped the s for in --enable-trans-sid ) in my config.nice-file i used to compile  all my php-versions with. 

Strange thing though is, that the phpinfo() stills shows the trans-sid to be enabled... Reading the note in the php.ini make this a little bit more clear: 

; use transient sid support if enabled by compiling with --enable-trans-sid.

the keyword here is "if"... I dunno if that is changed in cvs but it defintivly should, since is not very consitent ( at least to me..)

Sorry for all the trouble..  Recompiling 4.1.0 with a correct "--enable-trans-sid" seems to have fixed my problems.



 [2001-12-16 13:00 UTC] cmk@php.net
Checked with the code you provided and still can not reproduce this.
 [2001-12-16 13:06 UTC] cmk@php.net
Great that you could solve the problem.
And never mind about the trouble, user feedback is always appreciated.

Closing.
 [2001-12-16 17:40 UTC] yohgaki@php.net
Current PHP allows bogus configure options in many ways.
I hope this design is going to be changed.....
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon Feb 06 13:03:40 2023 UTC