php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14512 --enable-mbstr-enc-trans breaks parametr parsing
Submitted: 2001-12-14 06:11 UTC Modified: 2002-07-27 10:45 UTC
From: cech at debian dot org Assigned: hirokawa (profile)
Status: Closed Package: *Languages/Translation
PHP Version: 4.1.0RC1 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cech at debian dot org
New email:
PHP Version: OS:

 

 [2001-12-14 06:11 UTC] cech at debian dot org
When you run s script with like sep.php?+111+222+&test_param=abcde& the test_param won't get inserted into environment/GET['test_param']/HTTP_GET_PARAMS

It's also related to Debian bug #121403
http://bugs.debian.org/121403

Petr Cech

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-14 06:32 UTC] yohgaki@php.net
Hirokawa-san, 
Although query string is completely wrong, could you take a look at it? I've got

_GET["111_222_"]
for
phpinfo.php?+111+222+&test_param=abcde&%20the%20test_param

BTW, Language & Translation is for manuals ;)
Type = Unknown/Other Function, since mbstring module is missing in type :(

To reporter: Since query string invalid, this may not be fixed. Do you have any query string valid, yet produce wrong result?


 [2001-12-14 06:53 UTC] cech at debian dot org
Yes. the _GET["111_222_"] is the problem!
the query should be only
sep.php?+111+222+&test_param=abcde&

and this should be correct one. Strange is, that when you use
sep.php?&test_param=asdf&+123+234+

you get the correct result
 [2001-12-14 07:09 UTC] yohgaki@php.net
Oops sorry. Copy & paste magic ;)
I thought you are mixing + and %20, but it's not.
This should be fixed :)

 [2002-07-27 10:45 UTC] hirokawa@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a documentation 
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.

This problem is caused by a bug parameter handling in mbstring. The GET parameter without value was not correctly parsed in mbstring.
This bug is already fixed in PHP4-CVS/PHP-4.2.0dev-CVS by Edin Kadribasic.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 09:01:23 2020 UTC