php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14489 DSO PHP module compiling with gettext support is blocking Apache start
Submitted: 2001-12-13 11:55 UTC Modified: 2001-12-26 12:06 UTC
From: misch at host dot sk Assigned:
Status: Closed Package: Apache related
PHP Version: 4.1.0 OS: Cobalt Raq 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: misch at host dot sk
New email:
PHP Version: OS:

 

 [2001-12-13 11:55 UTC] misch at host dot sk
Hello

When I configure PHP with these options (including gettext support):

./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/sbin/apxs --with-gd=/usr/local --with-jpeg-dir=/usr/local/src/jpeg-6b --with-png-dir=/usr/local --with-zlib=/usr/local --enable-ftp --enable-trans-sid --with-imap=/usr/local --enable-safe-mode --with-gettext=/usr


Everything is fine (including configuration output and no errors or warnings on compiling) until I try to copy libphp4.so over old one and restart Apache.

Usualy when I'm restarting apache I can see this:

Shutting down Web Service: httpd
Setting up Web Service: Site home has invalid certificate: 4999 Certificate files do not exist.
Site site7 has invalid certificate: 4999 Certificate files do not exist.
/usr/sbin/httpd


but whe I try to restart Apache after module changing I can see this:


Shutting down Web Service: httpd
Setting up Web Service: Site home has invalid certificate: 4999 ssl_cant_files_missing
Site site7 has invalid certificate: 4999 ssl_cant_files_missing
/usr/sbin/httpd


You can see some messages changed and Apache is NOT running.


But When I don't include --with-gettext option evrything is running fine and Apache is running too, whith messages as in the first case.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-13 12:27 UTC] misch at host dot sk
I forgot this :

Apache/1.3.6 (Unix)

And I used RPM of gettext-0.10.35 and I've also tried to compile version 0.10.40 with same result
 [2001-12-13 23:06 UTC] sniper@php.net
Does you apache work without PHP ?

--Jani

 [2001-12-14 10:52 UTC] misch at host dot sk
Of course Apache is working. It's  RPM version from original Cobalt distribution.

Simply:

 just Apache IS working
 Apache + PHP 4.1.0 as DSO  IS working 
 Apache + PHP 4.1.0 as DSO --with-gettext IS NOT working (see previous comment)


Strange is that I can't see any error report. From console it seems Apache is running , but  it's NOT. Even more strange it is printing slightly other messages during APache 'Start'.

Thank You
 [2001-12-15 11:29 UTC] misch at host dot sk
Strace with working libphp4.so

http://michal.no-ip.com/~michal/ok.txt


Strace with NO working libphp4.so

http://michal.no-ip.com/~michal/bad.txt
 [2001-12-15 11:31 UTC] misch at host dot sk
These Straces are for command

..../httpd restart
 [2001-12-15 13:35 UTC] sniper@php.net
What if you 'stop' and 'start' it instead of 'restart' ?

 [2001-12-16 10:10 UTC] misch at host dot sk
It's the same.
 [2001-12-16 10:57 UTC] misch at host dot sk
I'm still wondering about this: when I compile php 4.1.0 as dso without --with-gettext and start Apache I can see this:

[root@cobalt apache]# /etc/rc.d/init.d/httpd start
Setting up Web Service: Site home has invalid certificate: 4999 Certificate files do not exist.
Site site7 has invalid certificate: 4999 Certificate files do not exist.
/usr/sbin/httpd

and Apache IS working

But when I compile it with optiion --with-gettext I see this (see messages):

[root@cobalt apache]# /etc/rc.d/init.d/httpd start
Setting up Web Service: Site home has invalid certificate: 4999 ssl_cant_files_missing
Site site7 has invalid certificate: 4999 ssl_cant_files_missing
/usr/sbin/httpd

and Apache is NOT running (no errors no records in error log)
Why are these apache messages changed ??????????



I was wondering about some mess in gettext versions so I  compiled 0.10.40 again and install in new dir and after use : --with-gettext=/home/michal/gettext  , but with the same reasult.



 [2001-12-16 12:34 UTC] cmk@php.net
I assume site7 has an ssl certificate defined, right?
So what happens when you remove that certificate?

As a note: I can not reproduce this bug on a Cobalt Raq 3 but I do not have hosts running ssl.
 [2001-12-16 18:53 UTC] sniper@php.net
status -> feedback.
 [2001-12-17 11:01 UTC] misch at host dot sk
It`s nothing about SSL and certificates. As you can see these messages are for both cases - when it is working and when it is not working either.

WHAT IS STRANGE IS THAT THESE MESSAGES ARE  !!!! CHANGED !!!


When I just add gettext support in PHP modul, how can it change these messages whenb Apache is starting.

Please look on these messages again.
 [2001-12-26 12:06 UTC] misch at host dot sk
I've solved this problem by installation second Apache (1.3.22) on other port . And there were no problems.

Thank you
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 29 02:03:33 2022 UTC