php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14487 Problem with stressed charachter (like ? or ?
Submitted: 2001-12-13 10:50 UTC Modified: 2002-06-18 16:34 UTC
From: s dot vigni at hor-net dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.0.6 OS: win NT 4.0 sp5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: s dot vigni at hor-net dot com
New email:
PHP Version: OS:

 

 [2001-12-13 10:50 UTC] s dot vigni at hor-net dot com
I have an MSSQL Server 2000 with a database with users data. some of this names a re frenche name with stressed charachter in. When i execute queries via odbc i have no problems and everything works fine, using MSSQL native functions doesn't work, instead of the stressed character i get some unreadable simbol. The webserver runs on a machine and the SQL server on another, the link is made via TCP protocol (i don't know if via named pipe works, but i doubt), on the client machine (the webserver) is installed only the client of SQL2000. I'm using Apache 1.3.20+modssl/php 4.0.6 on winnt 4 sp5 and the php_mssql.dll extension loaded. PHP is run as CGI not as a module.
I believe there is some problems in the way php_mssql.dll handles data. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-14 03:54 UTC] fjortiz at comunet dot es
We work with Spanish databases and had the same problem: try this:

Start Menu\Programs\Microsoft SQL Server\Client Network Utility.

Then uncheck the "ANSI to OEM conversion" and restart the web server. This worked for us.
 [2002-06-18 05:24 UTC] derick@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-06-18 16:34 UTC] sniper@php.net
not any PHP bug..

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 02:03:14 2021 UTC