php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14429 PSPELL CONFIG
Submitted: 2001-12-11 12:23 UTC Modified: 2001-12-14 04:09 UTC
From: taitgrove at hotmail dot com Assigned: vlad (profile)
Status: Closed Package: Pspell related
PHP Version: 4.1.0 OS: freebsd 4.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: taitgrove at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-12-11 12:23 UTC] taitgrove at hotmail dot com
I am running the following config line and getting a ok reponse on the inital configuration of PHP 4.1.0.

./configure  --prefix=/usr/local/php --with-mysql --with-apxs=/usr/local/apache/bin/apxs --with-pspell=/usr/local/aspell

But when I run the make I am getting the following errors:

Making all in pspell
/bin/sh /usr/local/php/libtool --silent --mode=compile gcc  -I. -I/usr/local/php/ext/pspell -I/usr/local/php/m
ain -I/usr/local/php -I/usr/local/apache/include -I/usr/local/php/Zend -I/usr/local/php/ext/mysql/libmysql -I/
usr/local/aspell/include/pspell -I/usr/local/php/ext/xml/expat/xmltok -I/usr/local/php/ext/xml/expat/xmlparse
-I/usr/local/php/TSRM  -DUSE_EXPAT -DXML_BYTE_ORDER=12 -g -O2  -c pspell.c
pspell.c: In function `php_if_pspell_check':
pspell.c:304: too few arguments to function `pspell_manager_check'
pspell.c: In function `php_if_pspell_suggest':
pspell.c:340: too few arguments to function `pspell_manager_suggest'
pspell.c: In function `php_if_pspell_store_replacement':
pspell.c:377: warning: passing arg 3 of `pspell_manager_store_replacement' makes integer from pointer without
a cast
pspell.c:377: too few arguments to function `pspell_manager_store_replacement'
pspell.c: In function `php_if_pspell_add_to_personal':
pspell.c:414: too few arguments to function `pspell_manager_add_to_personal'
pspell.c: In function `php_if_pspell_add_to_session':
pspell.c:451: too few arguments to function `pspell_manager_add_to_session'
*** Error code 1

Stop in /usr/local/php/ext/pspell.
*** Error code 1

Stop in /usr/local/php/ext/pspell.
*** Error code 1

Stop in /usr/local/php/ext.
*** Error code 1

Stop in /usr/local/php.

I am sure that pspell and aspell are installed properly.

Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-11 23:08 UTC] vlad@php.net
which versions of pspell and aspell are you using?
 [2001-12-11 23:17 UTC] vlad@php.net
meant assign it and place it into the right category too...
 [2001-12-12 12:54 UTC] taitgrove at hotmail dot com
PHP    ver 4.10
PSPELL ver .12.2
ASPELL ver .33.7.1

Thanks for the category fix, I didn't see it when I added the bug...
 [2001-12-12 14:55 UTC] vlad@php.net
From the quick look at the source of pspell, the author has broken source backward compatibility once again. Duh. Well, it's his toy, he can play with it, and I'll try to support the new API once again. 

For now, if you really-really need a spell checker in php, use a slightly older aspell (I'd say .32.x would work) and a corresponding version of pspell. I'll try to put changes up before the next release of php.

BTW: He is also renaming the whole thing back to aspell. We've gone through this before - we had aspell support, then Kevin changed the API to the point it wasn't worth fixing things that worked with old API, and named it pspell, so we created pspell module too. Now he is dumping that name once again... That will become kinda confusing for end users very soon.

Changing status to analyzed...

Thanks for the report:)


 [2001-12-12 16:06 UTC] taitgrove at hotmail dot com
So much for collaborative efforts between two great ventures. I will go ahead and downgrade to an older version.

Thanks for your time Vlad!

Happy holidays to you and the PHP community...
 [2001-12-12 19:05 UTC] vlad@php.net
actually, I might take my last statement back. Looks like that problem has been long since fixed.

From the line numbers I see in your bug report, it looks like you are using a very old revision of the pspell.c file - 1.12 or earlier (25 Oct 2000 or prior); the one shipped with php4.1.0 is 1.20.2.1.

Excuse me if I ask a dumb question, but are you *really* sure you are using php 4.1.0? If so, could you email me (vlad@php.net) your copy of ext/pspell/pspell.c file?

Thanks

changing status back to feedback...
 [2001-12-13 17:28 UTC] taitgrove at hotmail dot com
I emailed the file to you. It will be coming from my work address.

I am positive that it is 4.1.0. Released DEC. 10, 2001.

Also, I forgot to mention. It is looking for pspell inside of the location where I running the "make" for php. I installed pspell and aspell inside of the PHP directive and the make went fine but when I test any of the pspell functions it is saying that they are undefined.

Thanks,
 [2001-12-13 19:05 UTC] vlad@php.net
Believe it or not, you've got a *very* old version of pspell somehow. I'd most certainly say that this is not 4.1.0 version of php :( If you look at the pspell.c you sent me on line 19 you'll see:

/* $Id: pspell.c,v 1.12 2000/10/25 17:43:59 andrei Exp $ */


However, the version I downloaded yesterday has this:
/* $Id: pspell.c,v 1.20.2.1 2001/10/11 23:51:57 ssb Exp $ */

Notice the difference? Your version is a year older than the one in the 4.1.0 package. I'd suggest you re-download php-4.1.0:
http://www.php.net/downloads.php

or, if you really don't want to do that, get the latest pspell files from CVS:
http://cvs.php.net/cvs.php/php4/ext/pspell
and recompile. That should take care of all those problems.

Have a great day!:)

...closing...
 [2001-12-14 03:49 UTC] taitgrove at hotmail dot com
Vlad,

I am getting this error now:

Making all in pspell
/bin/sh /usr/local/php/libtool --silent --mode=compile gcc  -I. -I/usr/local/php/ext/pspell -I/
usr/local/php/main -I/usr/local/php -I/usr/local/apache/include -I/usr/local/php/Zend -I/usr/lo
cal/php/ext/mysql/libmysql -I/usr/local/include/pspell -I/usr/local/php/ext/xml/expat  -DUSE_EX
PAT -I/usr/local/php/TSRM -g -O2 -prefer-pic  -c pspell.c
pspell.c:39: pspell/pspell.h: No such file or directory
*** Error code 1

Stop in /usr/local/php/ext/pspell.
*** Error code 1

Stop in /usr/local/php/ext/pspell.
*** Error code 1

Stop in /usr/local/php/ext.
*** Error code 1

Stop in /usr/local/php.

Is this an operator error or is it looking into "php/pspell/" for the "pspell.h"?

Let me know if this is not a bug and I will go for support lists instead.

Thanks,
 [2001-12-14 03:50 UTC] derick@php.net
What was your configure line?

Derick
 [2001-12-14 04:07 UTC] taitgrove at hotmail dot com
Vlad,

I am getting this error now:

Making all in pspell
/bin/sh /usr/local/php/libtool --silent --mode=compile gcc  -I. -I/usr/local/php/ext/pspell -I/
usr/local/php/main -I/usr/local/php -I/usr/local/apache/include -I/usr/local/php/Zend -I/usr/lo
cal/php/ext/mysql/libmysql -I/usr/local/include/pspell -I/usr/local/php/ext/xml/expat  -DUSE_EX
PAT -I/usr/local/php/TSRM -g -O2 -prefer-pic  -c pspell.c
pspell.c:39: pspell/pspell.h: No such file or directory
*** Error code 1

Stop in /usr/local/php/ext/pspell.
*** Error code 1

Stop in /usr/local/php/ext/pspell.
*** Error code 1

Stop in /usr/local/php/ext.
*** Error code 1

Stop in /usr/local/php.

Is this an operator error or is it looking into "php/pspell/" for the "pspell.h"?

Let me know if this is not a bug and I will go for support lists instead.

Thanks,
 [2001-12-14 04:09 UTC] taitgrove at hotmail dot com
Disregard that last note I accidently hit 'F5'...

./configure --with-mysql --with apxs=/usr/local/apache/bin/apxs --with-pspell

No errors in the config
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Sep 26 12:01:25 2018 UTC