php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1441 PHP doesn't handle persistent connections that has been killed properly
Submitted: 1999-05-23 20:56 UTC Modified: 2001-02-10 13:20 UTC
From: pettern at thule dot no Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.0 OS: Linux Redhat 5.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: pettern at thule dot no
New email:
PHP Version: OS:

 

 [1999-05-23 20:56 UTC] pettern at thule dot no
Follow this procedure to reproduce the problem:

- Use sybase_pconnect() a few times to start up a few persistent connections.
- Start Sybase Central and kill off the PHP3 connections.
- Rerun the script that uses sybase_pconnect(). sybase_pconnect() will NOT fail, however any following sybase_query() will return 0, but no other error message. Looks like PHP3 tries to run the query on a persistent connection that has disappeared, but doesn't fail in sybase_pconnect() as it should. Ideally, it should check if a persistant connection is gone and not fail at all, but if it have to fail it should do it in the "right" function :-)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-12-13 16:12 UTC] joey at cvs dot php dot net
While I can confirm that the behavior is still there, I am moving it to
a feature/change request. It'd be nice, though....
 [2001-02-10 13:20 UTC] jimw@php.net
looks to me like 4.0 should handle this correctly.
 [2002-12-02 04:13 UTC] zeljkovr at net dot yu
ver 4.2.2 this behavior is still there
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 10:01:26 2019 UTC