php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14408 compiled failed for target ldap.lo
Submitted: 2001-12-10 13:23 UTC Modified: 2001-12-23 11:48 UTC
From: fowler at csufresno dot edu Assigned:
Status: Closed Package: LDAP related
PHP Version: php4-200112040900 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
28 + 27 = ?
Subscribe to this entry?

 
 [2001-12-10 13:23 UTC] fowler at csufresno dot edu
Compiling with the LDAP module fails with the following error. Am I missing something?

# make
...
...
/bin/sh /usr/software/php2/php4-200112040900/libtool --silent --mode=compile gcc  -I. -I/usr/software/php2/php4-200112040900/ext/ldap -I/usr/software/php2/php4-200112040900/main -I/usr/software/php2/php4-200112040900 -I/usr/netscape/server4/plugins/include -I/usr/software/php2/php4-200112040900/Zend -I/usr/local/ssl/include -I/opt/include -I/usr/local/include -I/usr/software/php2/php4-200112040900/ext/mysql/libmysql  -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/software/php2/php4-200112040900/TSRM -DTHREAD=1 -g -O2 -pthreads -DZTS -prefer-pic  -c ldap.c
ldap.c:2010: parse error before `LDAP_CONST'
ldap.c: In function `_ldap_rebind_proc':
ldap.c:2016: `params' undeclared (first use in this function)
ldap.c:2016: (Each undeclared identifier is reported only once
ldap.c:2016: for each function it appears in.)
ldap.c:2018: `tsrm_ls' undeclared (first use in this function)
ldap.c:2028: `url' undeclared (first use in this function)
ldap.c:2031: too few arguments to function `call_user_function_ex'
*** Error code 1
make: Fatal error: Command failed for target `ldap.lo'
Current working directory /usr/software/php2/php4-200112040900/ext/ldap
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /usr/software/php2/php4-200112040900/ext/ldap
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /usr/software/php2/php4-200112040900/ext
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-10 19:19 UTC] fowler at csufresno dot edu
I am using Netscape Directory SDK for C 4.14. The ldap header file being used while compliling is the one that came with the SDK. Is 4.14 not supported?

The configuration options I specified to build php were:

./configure \
--with-expat-dir=/usr/local \
--with-sablot=/usr/local \
--enable-xslt \
--with-xslt-sablot \
--with-openssl=/usr/local/ssl \
--with-curl=/opt \
--with-ldap=/usr/local \
--with-mysql \
--with-nsapi=/usr/netscape/server4 \
--with-iconv=/usr/local


 [2001-12-12 14:35 UTC] fowler at csufresno dot edu
compiled under php 4.1.0
 [2001-12-12 14:37 UTC] jpm@php.net
Closing then.

-- Joao
 [2001-12-12 14:38 UTC] sniper@php.net
Not so fast! This problem was reported to be in the latest CVS!
And I can confirm it. There are some missing TSRM macros in the
new stuff Stig added just recently.

 [2001-12-23 11:48 UTC] venaas@php.net
Sorry, my fault. I added some rebind_proc code which is
highly experimental. I thought my check would only be
satisfied for some OpenLDAP versions, didn't check with
Netscape SDK. I've now made sure it is only included for
OpenLDAP. Actually, since the check was triggered for
Netscape SDK, it's possible that I will add this feature
for Netscape also in the future. I checked for
ldap_set_rebind_proc() having three parameters. For those
APIs that only accept two, it is very ugly to implement it.
I'm pretty sure current ldap.c compiles for everyone. It's
nice if you try the latest snapshot. Let me know if there
still are problems.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 02:05:54 2022 UTC