php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14329 Mail() does not work
Submitted: 2001-12-03 15:18 UTC Modified: 2001-12-03 16:11 UTC
From: dr_jubi at hotmail dot com Assigned:
Status: Not a bug Package: *Mail Related
PHP Version: 4.1.0 OS: WindowsCE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dr_jubi at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-12-03 15:18 UTC] dr_jubi at hotmail dot com
ok when i run the mail script i get :
Warning: Failed to Connect in C:\Inetpub\docs\flatlinks\action.php on line 48

it says the error is in the Mail() line which is :
mail($to, $subject, $message, $headers);

i would realy apriechate any help,

here the script:
$to  = "$name1 <$mail1>";

$subject = "Hey, its $from";

$message = '
<html>
<head>
<title>Hello</title>
</head><body><left>
<?php echo $name1; ?>
<p>
Hi
</p>
</left></body></html>
';
	
	/* set the Content-type header to send html mail */
	$headers  = "MIME-Version: 1.0\r\n";
	$headers .= "Content-type: text/html; charset=iso-8859-1\r\n";

	mail($to, $subject, $message, $headers);

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-03 15:57 UTC] derick@php.net
Not a bug, seek for more support on the php-general@lists.php.net mailinglist.

Derick
 [2001-12-03 16:11 UTC] hholzgra@php.net
1) this is a bug tracking tool, not a support forum
   please ask support questions on the php-general
   mailing list (http://www.php.net/support.php)

2) you have read the configuration instructions
   on http://download.php.net/manual/en/ref.mail.php ?

3) your script would most likely fail even if
   the mail server talked to you

     $to  = "$name1 <$mail1>"; 

   is wrong, you have to quote the real name:

     $to  = "\"$name1\" <$mail1>";


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 05:01:24 2020 UTC