php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14271 Failure to compile using GD 2.0.1 because of conflicting types for gdIOCtx
Submitted: 2001-11-28 14:06 UTC Modified: 2002-05-23 21:09 UTC
Votes:6
Avg. Score:4.7 ± 0.5
Reproduced:5 of 5 (100.0%)
Same Version:1 (20.0%)
Same OS:1 (20.0%)
From: jmcastagnetto@php.net Assigned:
Status: Closed Package: GD related
PHP Version: 4.1.0 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jmcastagnetto@php.net
New email:
PHP Version: OS:

 

 [2001-11-28 14:06 UTC] jmcastagnetto@php.net
When compiling w/ GD 2.0.1, I found a warning and a fatal error:



In file included from gd.c:36:

php_gd.h:69: warning: static declaration for `gdImageColorResolve' follows non-static

gd.c:92: conflicting types for `gdIOCtx'

/asd/metallo1/server/libs/gd2/include/gd_io.h:19: previous declaration of `gdIOCtx'

make[3]: *** [gd.lo] Error 1

make[3]: Leaving directory `/asd/metallo1/sources/src_compile/php-4.1.0/ext/gd'

make[2]: *** [all-recursive] Error 1

make[2]: Leaving directory `/asd/metallo1/sources/src_compile/php-4.1.0/ext/gd'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/asd/metallo1/sources/src_compile/php-4.1.0/ext'

make: *** [all-recursive] Error 1



Using gcc 3.0.2, gd 2.0.1, and the following configuration line:



./configure --prefix=/export/dredox1/devel_server/php \

--with-config-file-path=/export/dredox1/devel_server/php \

--enable-track-vars --enable-magic-quotes \

--enable-inline-optimization --enable-xml --enable-wddx \

--enable-ftp --enable-calendar --enable-bcmath --enable-trans-id\

--with-zlib \

--with-gd=/asd/metallo1/server/libs/gd2 \

--enable-gd-native-ttf \

--with-xmlrpc \

--with-mysql=/export/dredox1/devel_server/mysql \

--with-apxs=/export/dredox1/devel_server/apache/bin/apxs



A quick and dirty kludge is to comment out line 92 in ext/gd/gd.c, which might break something else. Had not tested the compiled libphp4.so thoroughly.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-18 16:38 UTC] sniper@php.net
Does the PHP 4.2.0RC4 work any better? Do you have multiple
versions of GD library in your system? Are you sure there
aren't any stale header files from an old GD library?

 [2002-05-21 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-05-23 21:09 UTC] jmcastagnetto@php.net
Compiled OK w/ PHP 4.2.0
 [2003-01-10 01:03 UTC] mh at topms dot de
Hi,

I have the same problem using PHP 4.2.3 and GDlib 1.8.4 or the newer one, does not make any difference...
I only have one gd.h installed (doing this with .deb Packages for testing)... this seems to be a real bad thing...
I am testing this on a Debian 3.0 Machine, the funny thing is that on a SuSE 7.2 Machine with PHP 4.2.3 and GDlib 1.8.4 it works perfectly fine... the only difference would be that on there GDlib is compiled by hand... but still, it should also work when done with a .deb file, don't you think?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 13:05:53 2022 UTC