php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14151 Installed/Compiled Php4.0.6 with Oracle9i on Linux Red Hat7.2
Submitted: 2001-11-20 11:59 UTC Modified: 2002-03-12 00:00 UTC
Votes:5
Avg. Score:3.4 ± 0.8
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: liao4619 at uidaho dot edu Assigned:
Status: No Feedback Package: OCI8 related
PHP Version: 4.0.6 OS: Linux Red Hat 7.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: liao4619 at uidaho dot edu
New email:
PHP Version: OS:

 

 [2001-11-20 11:59 UTC] liao4619 at uidaho dot edu
I installed/compiled php4.0.6 with Oracle9i on RedHat 7.2 successfully. Following is the configure  command to compile/install php:
configure --with-oci8=/MyOracle_Home/  --with-apxs=/My_Apache_Home/bin/apxs
After compiling php, libphp4.so, and httpd.conf was generated in their apache directories. Apache1.3.19 (with Dynamic Shared Object) can be started without any problem. Php script: <? phpinfo(); ?>
shows that oci8 is enabled and current oracle version is 9.
However when use php to communicate with Oracle9i server, Netscape browser shows an error says that there is no data in html. If use same php code in another machine with php4.0.6 compiled with oracle8i, It can work with oracle9i server  without any problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-20 12:19 UTC] derick@php.net
Check your httpd error_log and see if it has things like "segmentation fault".
If so, read on how to make a backtrace at "bugs.php.net/how-to-report.php Add that backtrace to this report.

Derick
 [2001-11-21 12:50 UTC] sniper@php.net
Check this manual page:

http://www.php.net/manual/en/ref.oci8.php

And especially the part about linking Apache with libpthread.

--Jani

 [2001-12-13 06:29 UTC] sander@php.net
No feedback. Closing.
 [2001-12-21 12:45 UTC] liao4619 at uidaho dot edu
Yesterday I installed/Compiled Php4.1.0 with Oracle9i on Linux Red Hat 7.2 (kernel 2.4.7-10). All the installation work perfect, however when I connect with oracle database from netscape brower. The brower still popups a error window:

Netscape: Error
The documentation contained on data.
Try again later, or contact the server's administrator.

Check apache error_log:


[Fri Dec 21 09:14:46 2001] [notice] child pid 4972 exit signal Segmentation fault (11)
[Fri Dec 21 09:14:46 2001] [notice] child pid 2728 exit signal Segmentation fault (11)
[Fri Dec 21 09:16:21 2001] [notice] child pid 2726 exit signal Segmentation fault (11)
[Fri Dec 21 09:16:45 2001] [notice] child pid 4975 exit signal Segmentation fault (11)
[Fri Dec 21 09:16:45 2001] [notice] child pid 4974 exit signal Segmentation fault (11)
[Fri Dec 21 09:16:59 2001] [notice] child pid 5600 exit signal Segmentation fault (11)
[Fri Dec 21 09:16:59 2001] [notice] child pid 2729 exit signal Segmentation fault (11)
[Fri Dec 21 09:17:29 2001] [notice] child pid 2725 exit signal Segmentation fault (11)
[Fri Dec 21 09:17:29 2001] [notice] child pid 2724 exit signal Segmentation fault (11)
[Fri Dec 21 09:17:44 2001] [notice] child pid 5607 exit signal Segmentation fault (11)
[Fri Dec 21 09:17:44 2001] [notice] child pid 2727 exit signal Segmentation fault (11)
[Fri Dec 21 09:18:40 2001] [notice] child pid 5611 exit signal Segmentation fault (11)
[Fri Dec 21 09:18:40 2001] [notice] child pid 5608 exit signal Segmentation fault (11)
[Fri Dec 21 09:19:13 2001] [notice] child pid 5612 exit signal Segmentation fault (11)

Apache 1.3.19 was installed with libpthread,
 check "ldd /usr/local/apache/bin/httpd":
 libpthread.so.0 => /lib/i686/libpthread.so.0 (0x4002f000)
        libm.so.6 => /lib/i686/libm.so.6 (0x40044000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x40067000)
        libdb.so.2 => /usr/lib/libdb.so.2 (0x40094000)
        libdl.so.2 => /lib/libdl.so.2 (0x400a2000)
        libc.so.6 => /lib/i686/libc.so.6 (0x400a6000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

check "httpd -l" of apache configuration:
Compiled-in modules:
  http_core.c
  mod_so.c
suexec: disabled; invalid wrapper /usr/local/apache/bin/suexec


You may find my php 4.1.0 information from following URL:
http://hermes.campus.uidaho.edu/project/liao.php

If you visit following URL:
http://hermes.campus.uidaho.edu/project/login.php
you can see what happens to php!

If I visited same php scripts  located on another machine with php4.0.4 (complied with oracle8). The same php scripts can access data from my current oracle9iEE database server. It means that my current oracle9i EE server is working well and can communicate with php4.0.4 without any problem.

 
Please give me some suggestion about the error.
 [2001-12-21 13:01 UTC] liao4619 at uidaho dot edu
If you visit from following URL:
http://kellinux.cs.uidaho.edu/cs461/login.php 
you can find php can access my oracle9i EE database well. The php script on this machine(kellinux.cs.uidaho.edu)  is the same one from previous machine (hermes.campus.uidaho.edu). They both visit the Oracle9i database server on  hermes.campus.uidaho.edu.


 [2001-12-21 14:05 UTC] sander@php.net
Can you generate a backtrace? (http://bugs.php.net/bugs-generating-backtrace.php)
 [2001-12-21 19:42 UTC] liao4619 at uidaho dot edu
I followed backtrace report Instructions:
First:    I stop apache server by using following comand under root privilage
#/usr/local/apache/bin/apachectl stop
/usr/local/apache/bin/apachectl stop: httpd stopped

Second Under root privilage run httpd - X under gdb with:

#gdb /usr/local/apache/bin/httpd
GNU gdb Red Hat Linux (5.1-1)
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) run -X
Starting program: /usr/local/apache/bin/httpd -X
[New Thread 1024 (LWP 1971)]




After that I use web browser and access server to force the crash. I am surprised that I can connect with oracle server well. The only thing is  
the speed for access web is very slow. There is no gdb prompt appear, and 
there is no any message indication that there is a crash.


Following is php script to authorize into oracle:

/************************* Global Vars ******************************/
$user  = "xxxx";
$pswd  = "xxx";
$dbase = "(DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = hermes.campus.uidaho.edu)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = oracle.campus.uidaho.edu)
    )
  )"; 


function dbConnect()
{
    global $user, $pswd, $dbase;
    $con = OCILogon($user, $pswd, $dbase);
    
    if( OCIError($con) )
        ErrorAndExit( "Could not create connection to the database." );
    else
        return $con;
}



 [2002-02-07 03:03 UTC] jugsafari at rediffmail dot com
today I tried installing php4.1.1 on RedHat7.2 with Oracle9i
but it gives an error "unsupported version " . I went through a documentation where in it said that 4.1.1 has all fixups .the is a patch to fix this bug in php4.0.6 too but i donot find any help for php4.1.1 .

can I have any help on this ??


regards 
jags
 [2002-02-07 08:20 UTC] thies@php.net
what is you configure line?
also what re the last 10 lines of the outpit of your configure?


 [2002-03-12 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2007-09-25 11:44 UTC] yux at fdtsgd dot kfoh
http://www.meta-fx.com 
forex
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 13:03:49 2021 UTC