php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14122 wrong $PHP_SELF value when executing script with params
Submitted: 2001-11-19 14:48 UTC Modified: 2002-06-18 18:58 UTC
From: techtonik at tut dot by Assigned:
Status: Closed Package: Variables related
PHP Version: 4.0.6 OS: Windows 98 Apache 1.3.22
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: techtonik at tut dot by
New email:
PHP Version: OS:

 

 [2001-11-19 14:48 UTC] techtonik at tut dot by
* script index.php located alone in 'directory/site/'
When calling it like 'http://server/directory/site/index/index' variable
$SCRIPT_NAME = $PHP_SELF = $HTTP_SERVER_VARS["SCRIPT_NAME"] = $HTTP_SERVER_VARS["PHP_SELF"] = '/directory/site/index/index.php' instead of '/directory/site/index.php' 

* standart version 4.06 php4apache.dll & php4ts.dll
Build Date Jun 22 2001 running in safe mode.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-24 10:09 UTC] sander@php.net
Dupe of 13606
 [2002-06-18 18:58 UTC] sniper@php.net
See bug #13606

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 24 12:01:23 2020 UTC