php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14098 Configure PHP as an apache-module, but configure script is looking in wrong dir
Submitted: 2001-11-18 08:39 UTC Modified: 2001-11-18 08:47 UTC
From: blacknight at one-network dot org Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.6 OS: Debian/GNU Linux Potato 2.2r4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: blacknight at one-network dot org
New email:
PHP Version: OS:

 

 [2001-11-18 08:39 UTC] blacknight at one-network dot org
Your confgiurescript is looking for the httpd.h file in
/apache/src. But my apache version (1.3.22) isn't creating
this directory. The .h - files are in this version in the
include-dir, so your script won't find them. I needed to
create a symbolic link from include to src to get it done.

Maybe some users (newbies) will get problems there and won't
understand why configure can't find there file.

My compile command = ./configure
--with-apache=/usr/local/apache
--with-mysql=/usr/local/mysql --enable-transid

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-18 08:47 UTC] derick@php.net
--with-apache should point to the source tree, not to the install tree.

Not a bug > bogus
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 07:01:23 2020 UTC