php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14030 sybase ct_init fails
Submitted: 2001-11-12 08:58 UTC Modified: 2001-11-20 08:12 UTC
From: bdv at sea-aeroportimilano dot it Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.0.6 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bdv at sea-aeroportimilano dot it
New email:
PHP Version: OS:

 

 [2001-11-12 08:58 UTC] bdv at sea-aeroportimilano dot it
I build apache 1.3.20, Sybase ASE 12 and php 4.0.6 with this configuration:



./configure --with-apache=/usr/local/sorgenti/apache_1.3.14
            --with-sybase-ct=/database/sybase/OCS-12_0 
            

when the webserver  start this is the error:

Open Client Message:
Message number: LAYER = (5) ORIGIN = (3) SEVERITY = (5) NUMBER = (131)
Message String: ct_init(): network packet layer: internal net library error: Attempt to load protocol driver failed

Open Client Message:
Message number: LAYER = (5) ORIGIN = (3) SEVERITY = (5) NUMBER = (131)
Message String: ct_init(): network packet layer: internal net library error: Attempt to load protocol driver failed
[Mon Nov 12 13:49:33 2001] [notice] Apache/1.3.20 (Unix) PHP/4.0.6 configured -- resuming normal operations
[Mon Nov 12 13:49:33 2001] [info] Server built: Nov 12 2001 12:56:15

The sybase ct_init function don't work.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-20 08:11 UTC] bdv at sea-aeroportimilano dot it
The problem is fixed if you set LD_LIBRARY_PATH = $SYBASE/$SYBASE/lib
 [2002-02-21 04:53 UTC] ramesh_babu at hotmail dot com
To overcome this problem do one of the follows:
----------------------------------------------

Install the new libtli.sofile in the $SYBASE/lib directory.

Install the new libtli.so in a separate directory and set the environment variable LD_LIBRARY_PATH to this location.
 [2002-04-10 07:40 UTC] bharat_tg at yahoo dot com
On doing installjava -f "myjarfile.jar" -Sservername -Uusername -Ppasswd -Ddatabasename 
i am getting this error can anybody please let me know y is this error there and how can it be corrected.
CTLIB Message:  - Layer 6, Origin 8, Severity 5, Number 1, State 0:
ct_connect(): directory service layer: internal directory control layer error: There was an error encountered while binding to the directory service.
Thanks 
-bharat
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 05:05:45 2022 UTC