|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14029 can't dynamically load php_printer.dll extension
Submitted: 2001-11-12 08:46 UTC Modified: 2009-12-27 01:02 UTC
Avg. Score:4.7 ± 0.4
Reproduced:11 of 11 (100.0%)
Same Version:1 (9.1%)
Same OS:3 (27.3%)
From: dan at kokenge dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.0.6 OS: win/2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: dan at kokenge dot com
New email:
PHP Version: OS:


 [2001-11-12 08:46 UTC] dan at kokenge dot com
In php.ini I have:
enable_dl = On
extension_dir = "c:/PHP/extensions/"

All the extension dll's are in C:/PHP/extensions without any security.

PHP Program
$x = dl("php_cpdf.dll");
I get the following error:
Unable to load dynamic library 'c:/PHP/extension/php_printer.dll' - The specified procedure could not be found.
I have varified the fact that php_printer.dll is there!

I get the same error when I un-comment 
in php.ini

Help!!!! What am I doing wrong!
How do i get these to load.

Thanks for the help..


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-11 06:49 UTC] wloske at yahoo dot de
I have the same experiences for other dll's.
While for instance zlib loads perfectly pdf
and xslt refuse to load.

I also get the same error message but the files
are there and all permissions are correct.

 [2002-01-14 02:37 UTC]
Can you try the latest 4.1.1 package?
 [2002-02-15 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-02-19 07:52 UTC] annemarie dot denley at tnsofres dot com
I also have the following settings in the PHP.INI file.
enable_dl = On
extension_dir = "c:/program files/php/extensions"

Whenever I load any php page I get the following errors:
"OleMainThreadWndName: php.exe - Entry Point Not Found
The procedure entry point add_assoc_string could not be located in the dynamic link library php4ts.dll"

and then
Unable to load dynamic library 'c:/program files/php/extensions/php_printer/dll' - The specified procedure could not be found"

When calling phpinfo() I get the following information:
 c:\program files\php\extensions c:\program files\php\extensions 

I am running PHP v4.1.1 with Apache/1.3.17 (Win32) on Windows NT 4.0 build 1381
 [2004-12-08 13:52 UTC] ewald at webmail dot co dot za
i have the same problems as shown above..
Windows XP SP1

 [2009-12-27 00:52 UTC] gonza dot rnr at gmail dot com
I'm having the same problem with the DLL.

I've actually installed a little package called Appserv. It does not 
include php_printer.dll. However, I've downloaded it, copied it to the 
ext root, and still does not work.
 [2009-12-27 01:02 UTC]
printer is not in php core anymore. And "does not work" is a rather useless report :)
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Apr 18 18:01:28 2024 UTC