php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14010 --with-config-file-path=[DIR] ineffective
Submitted: 2001-11-10 16:01 UTC Modified: 2001-11-10 16:49 UTC
From: wguynes at wguynes dot mav dot net Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 4.0CVS-2001-11-10 OS: Linux Debian Potato
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wguynes at wguynes dot mav dot net
New email:
PHP Version: OS:

 

 [2001-11-10 16:01 UTC] wguynes at wguynes dot mav dot net
Build with --with-config-file-path=[DIR] in configure is ignored.

Here's my full configure line:

./configure '--with-config-file-path=/etc' \
    '--with-apxs=/usr/local/apache/bin/apxs' \
    '--with-mysql=/usr/local/mysql' \
    '--enable-track-vars' \
    '--with-zlib=shared,/usr' \
    '--with-xml' \
    '--with-gd=shared,/usr' \
    '--with-jpeg-dir=shared,/usr' \
    '--with-png-dir=shared,/usr' \
    '--with-xpm-dir=shared,/usr/X11R6' \
    '--with-ttf=shared,/usr' \
    '--with-t1lib=shared,/usr' \
    '--enable-gd-native-tt'

Please note that this is a work in progress.  There are other problems with this configure, but I do not believe them to be related to the --with-config-file-path problem.

-- 
William Guynes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-10 16:49 UTC] wguynes at wguynes dot mav dot net
Well, I ungzipped an entirely new snapshot and compiled completely fresh.  And the flag is now recognized.

You might look into this.
   "make clean" doesn't clear it
   "make distclean" doesn't clear it
   "rm config.cache" doesn't clear it

From what I can see, the only way to change your --with-config-file-path setting is for a completely fresh install.

-- 
William Guynes
 [2002-07-12 13:39 UTC] jiri dot mares at roehrer dot com
I had seem problem.
I installed it first time without --with-config-file-path=/etc. Then I putted it to config and recompile it again. It didn't helps!

Then I deleted last installation completly (delete it from /usr/local/lib/) and unzipped it again and reconfigure. Then it helps!

Jiri Mares
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 04:05:54 2022 UTC