php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13981 unresolved symbol loading shared libphp4.sl
Submitted: 2001-11-07 12:15 UTC Modified: 2002-06-04 04:24 UTC
From: g dot armanino at regione dot toscana dot it Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.0.6 OS: HP-UX 11.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: g dot armanino at regione dot toscana dot it
New email:
PHP Version: OS:

 

 [2001-11-07 12:15 UTC] g dot armanino at regione dot toscana dot it
I'm having problem compiling php4 (snapshot 200108300735 that solve a bug for informix) with openssl on hp-ux 11.0. Compilation goes ok, but iplanet web server fails loading libphp4.sl
I'm using openssl-0.9.6b compiled with shared library on the same system.

./configure \
	--with-informix=/opt/informix \
	--with-nsapi=/opt/netscape/server4 \
	--enable-track-vars \
	--enable-libgcc \
	--enable-shared \
	--with-mysql=no \
	--with-ldap=/opt/ldapsdk30 \
	--with-openssl=/opt/openssl

this is the error startinf iplanet 4.1 web server

/usr/lib/dld.sl: Unresolved symbol: sk_X509_free (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_pop_free (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_INFO_shift (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_num (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_push (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_INFO_free (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_new_null (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_value (code)  from /opt/netscape/server4/bin/libphp4.sl
/usr/lib/dld.sl: Unresolved symbol: sk_X509_INFO_num (code)  from /opt/netscape/server4/bin/libphp4.sl

obviously everything is ok compiling without "--with-openssl" option in configuration. 
Somewhere (probably on some openssl user mailing list) i read that this problem can be due to having programmed with respect to old version of openssl.

bye 
	giovanni
 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-04 04:24 UTC] mfischer@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 10:05:53 2022 UTC