php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13955 checking for png_info_init in -lpng... no
Submitted: 2001-11-06 11:23 UTC Modified: 2001-11-10 04:56 UTC
From: gerrit at familiehaase dot de Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.6 OS: CYGWIN_NT-4.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: gerrit at familiehaase dot de
New email:
PHP Version: OS:

 

 [2001-11-06 11:23 UTC] gerrit at familiehaase dot de
./configure aborts with this error:

checking for the location of libpng... yes
checking for png_info_init in -lpng... no
configure: error: libpng not found!

png.h says this:
/* Initialize the info structure (old interface 
   - NOT DLL EXPORTED) */
extern void png_info_init PNGARG((png_infop info_ptr));

So, why is there a check for a function from the not exported old interface which is obviously not public?

Probably there is a fix somewhere out there, I didn't found yet.

Ciao,

Gerrit

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-10 04:56 UTC] sniper@php.net
Changed the test to test for png_write_image().
But it's propably not the reason for the test to fail.
Check your config.log for more info. And ask further
support questions on the mailing lists:

http://www.php.net/support.php


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu May 30 21:01:33 2024 UTC