php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13941 ImageTTFText renders blocky text
Submitted: 2001-11-05 20:10 UTC Modified: 2001-12-01 15:36 UTC
From: james at computer-geek dot co dot uk Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: Slackware Linux 8.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: james at computer-geek dot co dot uk
New email:
PHP Version: OS:

 

 [2001-11-05 20:10 UTC] james at computer-geek dot co dot uk
Having battled for days trying to get the illusive ImageTTFText() feature to actually work, it seems that the text rendering is "blocky".

My build is as follows:

FreeType 2.0.5
GD 2.0.1
PHP 4.0.6

Try this link:

http://www.virtualisp.co.uk/test/actionbutton.php?t=Text

This is the PHP4.0.6 version.

I have an older server running 4.0.4pl1, gd1.8.3 and freetype 1.3.1 at:

http://resellers.virtualisp.co.uk:8080/icons/actionbutton.php?t=Text

This renders fine.

I can't get 4.0.4pl1 to work with FreeType on my Slackware 8 box and the only version that seems to compile is 4.0.6 with PNG, JPEG, GD2 and FreeType 2.

Is this a problem with GD/FreeType or PHP4.0.6?

I read an article in the general mailing list about this so tried to go back to 4.0.5 but keep getting errors with FreeType / PNG - it's as if 4.0.5 doesn't want to see FreeType 2 as debug.log keeps referencing -lttf instead of -lfreetype and -I/usr/local/include/freetype instead of -I/usr/local/include/freetype2

Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-10 05:06 UTC] sniper@php.net
Please try the latest CVS snapshot from http://snaps.php.net/

And also keep in mind that GD 2.0.1 is still BETA.
You should also try with GD 1.8.4.

--Jani

 [2001-12-01 15:36 UTC] sander@php.net
This is a known bug in GD2. Not a bug in PHP. Closing.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 17:03:58 2023 UTC