php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1388 IMAP and SNMP problem
Submitted: 1999-05-07 11:03 UTC Modified: 2002-06-16 08:30 UTC
From: gulyatt at vulcan dot achq dot dnd dot ca Assigned:
Status: Not a bug Package: Installation problem
PHP Version: 3.0.7 OS: Linux 2.0.38
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gulyatt at vulcan dot achq dot dnd dot ca
New email:
PHP Version: OS:

 

 [1999-05-07 11:03 UTC] gulyatt at vulcan dot achq dot dnd dot ca
Running Apache 1.3.6
the 2 PHP configure lines I used are:

configure --with-mysql --with-snmp --with-imap
AND
configure --with-mysql --with-imap --with-snmp

The problem is with imap and snmp compiled in to the module. As you can see,
I have tried 2 configures. Here's the problem.
With lconfigure 1 (snmp before imap), the snmp module works flawlessly, but
imp (a php mail client i'm trying out) will give "Document contains no data" when
accessing any imap function. If I switch the two, so imap is before snmp, the
opposite happens: snmp will produce the no data error, imap will work fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-05-10 14:25 UTC] gulyatt at vulcan dot achq dot dnd dot ca
sorry: the order of the configure options does NOT make a difference:
it comes down to SNMP never working if imap is installed...
 [1999-05-13 21:36 UTC] sas at cvs dot php dot net
Until the utility libraries conflict in some way, I don't see the possibility of SNMP/IMAP module influencing each other. Could you provide a backtrace for the IMAP problem?
 [2002-06-16 08:30 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC