php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13852 zlib file reading functions not working in Apache Module version
Submitted: 2001-10-27 16:58 UTC Modified: 2001-10-28 12:55 UTC
From: me at phillipoertel dot com Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4.0.4pl1 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: me at phillipoertel dot com
New email:
PHP Version: OS:

 

 [2001-10-27 16:58 UTC] me at phillipoertel dot com
most of the zlib file reading functions, like gzfile,gzread,gzpassthru,gzgetc do not work in the Apache Module version of php. 
the function returns no value - without outputting any error or warning; sometimes the webserver crashes.
when i switched php to run as cgi everything works as expected.
don't know if this has been fixed, couldn't find an entry in the bugfinder.
phil.

running extensions:
extension=php_zlib.dll
extension=php_sablot.dll
extension=php_gd.dll
extension=php_pdf.dll
demo script (test.gz would be ascii text):
$log = gzfile('test.gz');
foreach ($log as $l) echo "$l<br>";

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-28 11:37 UTC] jeroen@php.net
Probably not a bug (cgi does work, so very unlikely to be a bug in PHP or zlib). Ask support questions on http://www.php.net/support.php , or reopen if I'm wrong.

Try this:
Please check the location of your php.ini, that you're editing the right one. (check wether modifications show up in a phpinfo() page).

And check your error reporting level, set it to E_ALL (error_reporting(E_ALL); before anything). My guess is it's giving undefined function errors.
 [2001-10-28 12:55 UTC] me at phillipoertel dot com
even with error_reporting(E_ALL) i don't get any error messages from the script. i already had tried this.
i have both the cgi and win-apache server module version of php installed parallely. .php files are mapped to the php module and .phpc to cgi. that way it is very easy to compare the output of an identical script by just renaming it.
while as cgi the script outputs the textfile as expected, the module doesn't give me anything. 
i only have one php.ini on my system, which resides in winnt\system32\php.ini. it is used by the cgi and module.

<?php
error_reporting(E_ALL);
$log = gzfile('test.gz');
foreach ($log as $l) echo "$l<br>";
?>

phil.
 [2002-06-25 12:43 UTC] Neo at mpgz dot de
The Bug is still in there(PHP 4.2.1).OS WinXP, if PHP runs as modul it dosent do anything(not even an error) and if it runs as CGI it works correctly, plz do something.

Isn't there a workaround?

Neo
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 00:01:24 2020 UTC