php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13807 Incorrect display of NUMERIC(15,2) data
Submitted: 2001-10-24 02:24 UTC Modified: 2002-04-13 14:43 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: deon at compute dot co dot za Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.0.6 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: deon at compute dot co dot za
New email:
PHP Version: OS:

 

 [2001-10-24 02:24 UTC] deon at compute dot co dot za
Using NUMERIC(15,2) in Windows IB6 as money fields all displays on the web page appears as ###.20. For example 123.45 appears as 123.20. The precision value seems to be displayed instead of the actual decimal value.
I believe the same is happening with DECIMAL(?.?) 

P.S. I keep getting the W32.HLLW.Bymer virus going into pHp.com.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-13 14:43 UTC] daniela@php.net
The version of PHP that this bug was reported in is too old. 
Please try the php-4.2.0RC3 from http://www.php.net/~derick/ 

If you are still able to reproduce the bug, please change the PHP
version on this bug report to the version you tested and change 
the status back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 17:05:44 2022 UTC